Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Packard Bell EasyNote TX86 laptop stopped recognizing my 1 TB Toshiba Store Art hard drive. It worked fine until now, and it still works on other computers. Other USB devices (including storage) work, and I've tried plugging it in every port, to no avail. When I plug it in it spins up, but Windows doesn't react at all (it's not in disk management), Linux doesn't write anything in dmesg and I can't see it in BIOS setup. I didn't use it at all today, apart from plugging it into a freshly-installed Windows 7 machine once (where it worked).

What can I do? Which device is to blame here?

EDIT: One more thing. I unplugged the drive while the laptop was hibernated. Google says this might be the problem and it might have something to do with resetting the USB Host Controller.

share|improve this question

2 Answers 2

Hibernate may cause some problems - but that wouldn't explain it not working in Linux or after a reset.

You say other devices have worked - all I can think of / suggest is, have you tried a different USB socket in case that it is the socket that is damaged. Again, if it was related to hibernate, a restart should solve it and a restart to Linux should not be affected at all.

share|improve this answer
    
I tried all of them. What's really frustrating is that I don't know if the hard drive or the laptop is to blame. –  vahokif Sep 28 '10 at 20:57
    
@Vahokif - I think it is the laptop to blame, but the fact that it doesn't work in Linux either, I am clueless. Sorry I can't help further. –  William Hilsum Sep 28 '10 at 21:11

Try to go in Computer management by right click on My Compute Icon and go to Device Manager>Usb Serial Port and uninstall all USB Root HUB. And reboot your computer and then connect your HDD.

enter image description here

As in my PC all USB Root Hub are showing normally but if any one is not working then windows show a Yellow Mark on it then uninstall it and when you will reboot windows will find the new hardware and install automatically for your system. Hope it will work for you.

share|improve this answer
    
Thanks, this worked for me! My USB 3 hub was not working, but right-click-uninstall and then right-click-scan PC for hardware changes in device manager fixed it. –  MGOwen Aug 28 at 3:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.