Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed MySQL on Fedora13. Now, when I try to create a database, it denies me access. I tried resetting the password and it does not recognize my system root. I tried resetting password with an init-file containing:

UPDATE mysql.user SET Password=PASSWORD('MyNewPass') WHERE User='root';

I tried uninstall and then reinstall and it is still not working.

I am new to Linux and not comfortable with the filesystem. Talk to me like I'm four.

Thank you, kindly.

share|improve this question

If anyone else has this problem, I resolved it. At least I think I did. I can log in now and access MySQL. I removed, erased and reinstalled MySQL several times, along with deleting all the folders I could find that had mysql in them. This did not work. Don't try that. I finally stumbled upon this procedure, buried in a forum somewhere.

  1. Update the packages
  2. Type:

    hostname localhost.localdomain
    mysql_install_db --skip-name-resolve --force

Done. HTH

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.