Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've installed 12 GB of memory on my Windows 7 computer, and yes it is a 64 bit computer. I can see the memory in bios, as well as in the properties of the computer, but when looking in the properties it says "Installed memory (RAM): 12,0 GB (2,93 GB usable)"... I want to use all my memory. I've tried to start msconfig and changed the maximum memory in the Advanced Options under the boot tab to the maximum value, but after each boot it shows up as 0 again.

Screenshot shows the properties of the computer.

alt text

EDIT: Solved, solution was to upgrade bios. Pretty weird considering the computer is only one month old or so.

share|improve this question

migrated from stackoverflow.com Sep 29 '10 at 13:40

This question came from our site for professional and enthusiast programmers.

    
Is the memory recognized at POST? –  Vasileios Lourdas Sep 29 '10 at 13:28
add comment

6 Answers 6

up vote 4 down vote accepted

I finally solved, the problem seemed to be an outdated bios. After upgrading the bios the memory shows up as it should. I should have thought of that before, but the computer is only two weeks old so that did came to mind.

share|improve this answer
add comment

I've had similar problem in the past, when I had some faulty RAM. It may not be your issue, but you can confirm this by running Memtest86 overnight.

Additionally, confirm that your mobo can handle 12GB, and if there are any further constraints. You might find help on the manufacturers forums. Sometimes you'll find that a board supports say 12GB but that it requires a certain type/brand/speed sticks.

share|improve this answer
    
Memtest86 want do it since i think it is targeting the x86 platform. –  Tomas Jansson Sep 29 '10 at 14:00
1  
@mastoj Why wouldn't memtest86+ work? It does support all newest processors. –  AndrejaKo Sep 29 '10 at 14:52
    
I might have been wrong there, I thought from the name of it and after just a quick read that it was targeting the x86 platform. And I was pretty sure, as you was hinting, that this was not my problem. As I answered further down the solution was to upgrade bios. –  Tomas Jansson Sep 30 '10 at 9:00
    
@mastoj You should post that in an answer and select it. This way the question will be considered solved by the sotware. –  AndrejaKo Sep 30 '10 at 9:18
    
I know... I posted the answer yesterday but I can't select it until tomorrow for some reason. –  Tomas Jansson Sep 30 '10 at 13:59
show 1 more comment

Have you checked if you have Maximum Memory configured?

  1. Run msconfig.
  2. Choose the Boot tab.
  3. Click the Advanced Options button.
  4. Turn off the Maximum Memory option.
  5. Close the dialog boxes, and then reboot the system.

enter image description here

share|improve this answer
add comment

I thought I had this fixed. My solution below helped. But I just discovered that now when I refresh msinfo32 again and again, Available Physical Memory is gradually declining with time.

When I first checked it it was 6.05, now it's 4.89, or over a gigabyte lost in an hour.

And it should be more like 7.xx. After a reboot it start out higher and after many minutes is much lower. Dare I say a system memory leak, or what?


[My previous answer:] I had to update my chipset driver. Finally after many years of hunting for this solution!

I'm running Window 7 x64 on a hp pavilion dv7t-2200. Have 8gb installed, but was only seeing about 1/3 of that used at most ever (via the ms cpu/memory usage 'gadget' indicator).

First I updated bios but that didn't do it.

But in the process I learned of a very good tool. Check this out: Run msinfo32 at the start/search box.

It reported that I had:

"Total Physical Memory (RAM)          8.00 GB", and 
"Total Physical Memory                7.97 GB", but that 
"Available Physical Memory was only   3.9x GB".  (aprox., because I didn't record the actual number)

Once I updated the chipset driver I got "Available Physical Memory 6.49 GB". I don't know why it's not closer to 8 gb, but I'm happy to have gotten it to up it to this. Perhaps part of it is used up in managing the other part of it.

share|improve this answer
add comment

Maybe it's a hardware limitation. Make sure your motherboard supports 12 GB.

share|improve this answer
2  
Motherboards typically don't report more memory than they support. E.g., if it only supported 8G, it would report 8G even though he has 12G installed. –  TMN Sep 29 '10 at 13:59
    
Motherboard support 16 GB, at least. –  Tomas Jansson Sep 29 '10 at 13:59
add comment

I understand that you have a 64 bit OS, but I would still try the technique used in the following link. Something may have changed on your machine and caused it to understand more than 3GB of RAM. The only other problem could be motherboard limits.

http://www.raymond.cc/blog/archives/2009/08/19/make-windows-7-and-vista-32-bit-x86-support-more-than-4gb-memory/

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Canadian Luke Dec 20 '13 at 18:30
    
Sorry @CanadianLuke. I answered this question several years ago and do not know the circumstances on why I was so brief in my answer. Since it has been such a long time since I answered this question and there is an answer that has already been chosen as correct, I do not feel it is necessary to revise the answer further. As you can see from my other answer, I am usually much more complete with my answers and include links if they are beneficial. –  David Dec 21 '13 at 3:25
    
Absolutely, I just wasn't looking at the rep you already had, or that the question was old and asked long ago. Canned response, sorry bud –  Canadian Luke Dec 21 '13 at 5:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.