Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Apple TV onto which I installed Ubuntu Karmic. It works great save a small problem with SSH.

The openssh-server package is installed and configured and can be started with sudo /etc/init.d/ssh start fine. When the machine is rebooted, however, it never starts itself up as it should.

rcconf reports that SSH is enabled for autostart on boot. Grepping /var/log/syslog, /var/log/messages, and /var/log/dmesg for 'ssh' yields no results. I removed and readded ssh with the following: sudo update-rc.d ssh start 40 2 3 4 5 . stop 19 0 1 6 ..

Does anyone know what could be causing this to not start up properly?

share|improve this question
up vote 0 down vote accepted

Not sure as to the reason for your problem, but you could put the start command into /etc/rc.local and see if that works. It will be run as root, so don't put in the sudo.

/etc/rc.local

...
/etc/init.d/ssh start
exit 0
share|improve this answer
    
My rc.local isn't even being run. Ugh. Symlinks are present in the rc#.d folders and I tried redoing them with update-rc.d but they still don't fire. – Jake Wharton Sep 30 '10 at 12:40
    
I have larger underlying problems it seems. Thanks for the help. – Jake Wharton Sep 30 '10 at 13:23
    
Wish I could be more help, but it appears this problem goes a bit deeper, beyond my knowledge. Maybe the system is not switching run levels appropriately? – SuperJames Sep 30 '10 at 13:51
    
All of the guides for the Apple TV use Hardy except for one that used Karmic which I chose to follow. I did a complete fresh install with the 10.10 beta out of frustration which is working immensely better thankfully. – Jake Wharton Oct 1 '10 at 13:50

If the other system startup options aren't working for you, try going to:

System --> Preferences --> Startup Applications

and adding the command there by using the "Add" button.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .