Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Im attempting to install Bugzilla on my local development server (based on a windows machine). My server is the standard xampp install. Ive got to the point where i need to install the relevant perl modules but one of them (Template-Toolkit) does not seem to be recognised. I originally attempted to install it via ppm, but on running bugzillas checksetup file, at the very end i get the following message:

COMMANDS TO INSTALL REQUIRED MODULES (You *must* run all these commands
and then re-run this script):

    ppm install Template-Toolkit
*** Installation aborted. Read the messages above. ***

but ive already run ppm install Template-Toolkit and it worked with no apparent errors. After seeing another post on here, i tried the the CPAN bugzilla bundle:

cpan Bundle::Bugzilla

but again, no luck. Is there anything else i can try to get this installed?

im using windows 7 pro 64bit and perl 5.10.1 (that came with the xampp install)

Any help would be appreciated.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

xampp installs Perl 5.10.1, but Bugzilla only works with 5.8.1

share|improve this answer
Any version starting with 5.8.1 – Alexandr Ciornii Oct 31 '10 at 23:05

You need to install Template: ppm install Template.

P.S. Strawberry Perl is easier to use on Windows.

share|improve this answer

I have Activeperl version 5.20.1 installed separately from xampp. And I am getting the following error when accessing bugzilla:

Software error:

Template creation failed: failed to create context: failed to load Bugzilla/Template/ Can't locate Bugzilla/Template/ in @INC (you may need to install the Bugzilla::Template::Context module) (@INC contains: . lib C:/Perl64/site/lib C:/Perl64/lib) at C:/Perl64/site/lib/Template/ line 82.
For help, please send mail to the webmaster (postmaster@localhost), giving this error message and the time and date of the error.

How do I resolve this error so that I can install the template-Toolkit package for bugzilla?

share|improve this answer
This does not appear to answer the author's question. – Ramhound Mar 17 at 14:06
If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. – Art Gertner Mar 17 at 14:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.