Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I downloaded a DMG of some commercial Mac software (CSSEdit) but I found that the DMG wouldn't mount. I tried another image from the same company, and then a number of images I had laying around from other software. About half of them mount and half don't. The error is always "no mountable file systems"

My google-foo reveals only some isolated incidents, and the repeated suggestion to reboot (I have, twice). The disk will not mount from Disk Utility either (nor does attempting to verify or repair it from there have any effect). I've also tried re-downloading this image several times using several different programs.

I recently updated to 10.5.8 in case that's relevant.

Here's a paste of what I get when I try to mount the DMG from the command line.

loki:Downloads peter$ hdiutil attach CSSEdit\ 2.6.dmg -Verbose
Initializing…
DIBackingStoreInstantiatorProbe: interface  0, score      100, CBSDBackingStore
DIBackingStoreInstantiatorProbe: interface  1, score    -1000, CBundleBackingStore
DIBackingStoreInstantiatorProbe: interface  2, score    -1000, CRAMBackingStore
DIBackingStoreInstantiatorProbe: interface  3, score      100, CCarbonBackingStore
DIBackingStoreInstantiatorProbe: interface  4, score    -1000, CDevBackingStore
DIBackingStoreInstantiatorProbe: interface  5, score    -1000, CCURLBackingStore
DIBackingStoreInstantiatorProbe: interface  6, score    -1000, CVectoredBackingStore
DIBackingStoreInstantiatorProbe: selecting CBSDBackingStore
DIBackingStoreInstantiatorProbe: interface  0, score      100, CBSDBackingStore
DIBackingStoreInstantiatorProbe: interface  1, score    -1000, CBundleBackingStore
DIBackingStoreInstantiatorProbe: interface  2, score    -1000, CRAMBackingStore
DIBackingStoreInstantiatorProbe: interface  3, score      100, CCarbonBackingStore
DIBackingStoreInstantiatorProbe: interface  4, score    -1000, CDevBackingStore
DIBackingStoreInstantiatorProbe: interface  5, score    -1000, CCURLBackingStore
DIBackingStoreInstantiatorProbe: interface  6, score    -1000, CVectoredBackingStore
DIBackingStoreInstantiatorProbe: selecting CBSDBackingStore
DIFileEncodingInstantiatorProbe: interface  0, score    -1000, CMacBinaryEncoding
DIFileEncodingInstantiatorProbe: interface  1, score    -1000, CAppleSingleEncoding
DIFileEncodingInstantiatorProbe: interface  2, score    -1000, CEncryptedEncoding
DIFileEncodingInstantiatorProbe: nothing to select.
DIFileEncodingInstantiatorProbe: interface  0, score      900, CUDIFEncoding
DIFileEncodingInstantiatorProbe: selecting CUDIFEncoding
DIFileEncodingNewWithBackingStore: CUDIFEncoding
DIFileEncodingNewWithBackingStore: instantiator returned 0
DIFileEncodingInstantiatorProbe: interface  0, score    -1000, CSegmentedNDIFEncoding
DIFileEncodingInstantiatorProbe: interface  1, score    -1000, CSegmentedUDIFEncoding
DIFileEncodingInstantiatorProbe: interface  2, score    -1000, CSegmentedUDIFRawEncoding
DIFileEncodingInstantiatorProbe: nothing to select.
DIDiskImageInstantiatorProbe: interface  0, score        0, CDARTDiskImage
DIDiskImageInstantiatorProbe: interface  1, score        0, CDiskCopy42DiskImage
DIDiskImageInstantiatorProbe: interface  2, score    -1000, CNDIFDiskImage
DIDiskImageInstantiatorProbe: interface  3, score     1000, CUDIFDiskImage
CRawDiskImage: data fork length 0x000000000022EE83 (2289283) not a multiple of 512.
DIDiskImageInstantiatorProbe: interface  5, score     -100, CRawDiskImage
DIDiskImageInstantiatorProbe: interface  6, score     -100, CShadowedDiskImage
DIDiskImageInstantiatorProbe: interface  7, score        0, CSparseDiskImage
DIDiskImageInstantiatorProbe: interface  8, score        0, CSparseBundleDiskImage
DIDiskImageInstantiatorProbe: interface  9, score    -1000, CCFPlugInDiskImage
DIDiskImageInstantiatorProbe: interface 10, score     -100, CWrappedDiskImage
DIDiskImageInstantiatorProbe: selecting CUDIFDiskImage
DIDiskImageNewWithBackingStore: CUDIFDiskImage
DIDiskImageNewWithBackingStore: instantiator returned 0
Verifying…
Verification completed…
Error 0 (Unknown error: 0).
expected   CRC32 $DA5349F2
Attaching…
DI_kextWaitQuiet: about to call IOServiceWaitQuiet...
DI_kextWaitQuiet: IOServiceWaitQuiet took 0.000008 seconds
2009-08-06 21:48:36.456 diskimages-helper[1607:381b] -serveImage: attaching drive
{
    autodiskmount = 1;
    "hdiagent-drive-identifier" = "921062E3-5965-477A-85C8-C93979468CF9";
    "unmount-timeout" = 0;
}
2009-08-06 21:48:36.462 diskimages-helper[1607:381b] -serveImage: connecting to myDrive 0x00004707
2009-08-06 21:48:36.463 diskimages-helper[1607:381b] -serveImage: register _readBuffer 0x0x468000 with myDrive 0x0x0
2009-08-06 21:48:36.463 diskimages-helper[1607:381b] -serveImage: activating drive port 0x0x4807
2009-08-06 21:48:36.463 diskimages-helper[1607:381b] _serveImage: set cache enabled=TRUE returned SUCCESS.
2009-08-06 21:48:36.464 diskimages-helper[1607:381b] _serveImage: set on IO thread=TRUE returned SUCCESS.
2009-08-06 21:48:36.464 diskimages-helper[1607:381b] -serveImage: starting server loop - myPort is 0x0x4807
Volume check completed…
Mounting…
^[[Adiskimages-helper: DI_kextDriveGetRequest returned 0x00000025 (37) ((os/kern) object terminated).
Attaching…
Error 109 (no mountable file systems).
Finishing…
DIHLDiskImageAttach() returned 109
hdiutil: attach failed - no mountable file systems


loki:Downloads peter$ hdiutil imageinfo CSSEdit\ 2.6.dmg -Verbose
hdiutil: imageinfo: processing "CSSEdit 2.6.dmg"
DIBackingStoreInstantiatorProbe: interface  0, score      100, CBSDBackingStore
DIBackingStoreInstantiatorProbe: interface  1, score    -1000, CBundleBackingStore
DIBackingStoreInstantiatorProbe: interface  2, score    -1000, CRAMBackingStore
DIBackingStoreInstantiatorProbe: interface  3, score      100, CCarbonBackingStore
DIBackingStoreInstantiatorProbe: interface  4, score    -1000, CDevBackingStore
DIBackingStoreInstantiatorProbe: interface  5, score    -1000, CCURLBackingStore
DIBackingStoreInstantiatorProbe: interface  6, score    -1000, CVectoredBackingStore
DIBackingStoreInstantiatorProbe: selecting CBSDBackingStore
DIFileEncodingInstantiatorProbe: interface  0, score    -1000, CMacBinaryEncoding
DIFileEncodingInstantiatorProbe: interface  1, score    -1000, CAppleSingleEncoding
DIFileEncodingInstantiatorProbe: interface  2, score    -1000, CEncryptedEncoding
DIFileEncodingInstantiatorProbe: nothing to select.
DIFileEncodingInstantiatorProbe: interface  0, score      900, CUDIFEncoding
DIFileEncodingInstantiatorProbe: selecting CUDIFEncoding
DIFileEncodingNewWithBackingStore: CUDIFEncoding
DIFileEncodingNewWithBackingStore: instantiator returned 0
DIFileEncodingInstantiatorProbe: interface  0, score    -1000, CSegmentedNDIFEncoding
DIFileEncodingInstantiatorProbe: interface  1, score    -1000, CSegmentedUDIFEncoding
DIFileEncodingInstantiatorProbe: interface  2, score    -1000, CSegmentedUDIFRawEncoding
DIFileEncodingInstantiatorProbe: nothing to select.
DIDiskImageInstantiatorProbe: interface  0, score        0, CDARTDiskImage
DIDiskImageInstantiatorProbe: interface  1, score        0, CDiskCopy42DiskImage
DIDiskImageInstantiatorProbe: interface  2, score    -1000, CNDIFDiskImage
DIDiskImageInstantiatorProbe: interface  3, score     1000, CUDIFDiskImage
CRawDiskImage: data fork length 0x000000000022EE83 (2289283) not a multiple of 512.
DIDiskImageInstantiatorProbe: interface  5, score     -100, CRawDiskImage
DIDiskImageInstantiatorProbe: interface  6, score     -100, CShadowedDiskImage
DIDiskImageInstantiatorProbe: interface  7, score        0, CSparseDiskImage
DIDiskImageInstantiatorProbe: interface  8, score        0, CSparseBundleDiskImage
DIDiskImageInstantiatorProbe: interface  9, score    -1000, CCFPlugInDiskImage
DIDiskImageInstantiatorProbe: interface 10, score     -100, CWrappedDiskImage
DIDiskImageInstantiatorProbe: selecting CUDIFDiskImage
DIDiskImageNewWithBackingStore: CUDIFDiskImage
DIDiskImageNewWithBackingStore: instantiator returned 0
Format: UDZO
Backing Store Information:
    Class Name: CUDIFEncoding
    Backing Store Information:
    	Name: CSSEdit 2.6.dmg
    	URL: file://localhost/Users/peter/Downloads/CSSEdit%202.6.dmg
    	Class Name: CBSDBackingStore
    URL: file://localhost/Users/peter/Downloads/CSSEdit%202.6.dmg
    Name: CSSEdit 2.6.dmg
Partition Information:
    0:
    	Checksum Value: $675BE18B
    	Partition Number: 0
    	Checksum Type: CRC32
    	Name: gehele schijf (Apple_HFS : 0)
Checksum Type: CRC32
partitions:
    appendable: true
    partition-scheme: none
    block-size: 512
    burnable: true
    partitions:
    	0:
    		partition-length: 18432
    		partition-synthesized: true
    		partition-hint: Apple_HFS
    		partition-name: whole disk
    		partition-filesystems:
    			HFS+: 
    		partition-start: 0
Properties:
    Partitioned: false
    Software License Agreement: false
    Compressed: true
    Kernel Compatible: true
    Encrypted: false
    Checksummed: true
Checksum Value: $DA5349F2
Size Information:
    Total Bytes: 9437184
    Compressed Bytes: 2289283
    Compressed Ratio: 0.26906180417644582
    CUDIFEncoding-bytes-wasted: 0
    Sector Count: 18432
    Total Non-Empty Bytes: 8507904
    Total Empty Bytes: 929280
    CUDIFEncoding-bytes-in-use: 2289283
    CUDIFEncoding-bytes-total: 2289283
Class Name: CUDIFDiskImage
Format Description: UDIF read-only compressed (zlib)
udif-ordered-chunks: true
Segments:
    0: /Users/peter/Downloads/CSSEdit 2.6.dmg
Resize limits (per hdiutil resize -limits):
    16624	18432	18432
hdiutil: imageinfo: result: 0
share|improve this question
    
An update on this. I've replaced my hard drive with an SSD, cloning all files over. Using this new drive (but same OS, configs, etc) I downloaded Little Snitch fresh (trying both the stable and nightly versions) and got this error consistently. My problem is definitely in software. –  Peter Burns Feb 9 '12 at 19:37
    
I was using a .sparseimage disk image to hold a FCPX event and project. I was able to access it many times, but then all of a sudden, I got the 'no mountable file system' error. I tried rebooting and repairing permissions with no luck. I then tried simonair's advice and Terminal commands, and was able to mount the disk again. Whew. I definitely recommend trying his advice, as it really saved my bacon. –  user122001 Mar 8 '12 at 14:10
add comment

9 Answers

I have just had the same problem, with a disk image created by Disk Utility itself. In my case, the disk image is whole disk image, i.e. it contains a bare filesystem, no partition map whatsoever. Neither Disk Utility nor hdiutil attach disk.dmg would work, both complaining about the dreaded "no mountable file systems" issue.

What helped was to mount it from the command line, in two easy steps:

hdiutil attach -noverify -nomount disk.dmg

This only creates the device node. Now run

diskutil list

and note the diskN part of your image, where N is a positive integer.

Finally, to mount the device, do

diskutil mountDisk /dev/diskN

where diskN is the device identifier you determined before.

Note that you are mounting the entire disk, whereas normally you would mount a slice, such as disk0s2.

Be aware that this helps if your problem is with a disk image similar to mine. Nonetheless, it should still work with partitioned disk images, see man diskutil.

share|improve this answer
    
Thanks, helped me a lot to finally burn Ubuntu 12.04 onto a disk. :) –  Florian Pilz Apr 23 '12 at 7:07
1  
I just noticed, that it's not necessary to mount the disk to burn it. hdiutil burn disk.iso works perfectly fine, even if I can't mount the disk. –  Florian Pilz Apr 30 '12 at 9:12
    
Guys, you just saved my life, can I sort of +9999? –  FrancescoMM Jan 23 at 10:24
add comment

Generally, if you are receiving "No mountable file system", that generally means that the disk image is corrupt or damaged.... Try re-downloading the disk image, or downloading the disk image from within another browser....

I have seen infrequent issues when Firefox has been used to download an disk image. Very uncommon, but it has happened...

share|improve this answer
    
I've re-downloaded the image about ten times through several different browsers. Thanks for the advice though. –  Peter Burns Sep 2 '09 at 23:20
    
My image was a backup of the disk made with DiskUtil... –  FrancescoMM Jan 23 at 15:37
add comment

I had the same problem on an AES-128 encrypted dmg containing all of my most essential files, the kind worth spending thousands of dollars to have Drivesavers recover. I couldn't even copy the dmg to another drive (could not be read or written -36). My G4 (yes, I'm old school) is running 10.4.11.

This worked:

  1. Booted from external hard drive also running 10.4.11.
  2. Used Stellar Phoenix quick recovery to find and recovery the dmg to the external hard drive. All subsequent work was on that copy.
  3. Ran that drives OS versions built in Disk Utility.
  4. In Disk Utility, went to "File" menu upper left, chose "Open Disk Image".
  5. Mounted volume then appears as sub dir of dmg in left column, just as any other volume does from it's hard drive, except greyed out (ie: invisible).
  6. I use tinkertool to show all my invisible files, the mounted volume still did not appear on the desktop.
  7. Attempted repair using Disk Utility without success.
  8. BUT, launched DiskWarrior 4.0 and the mounted volume appeared there as well.
  9. Ran directory repair (plain, not scavenge) and at the "Report" stage chose "Preview".
  10. DiskWarrior reports new and old versions now appear on dektop.
  11. I couldn't see either on my desktop (I had too much garbage there & may have missed it), but opening a new Finder window did show the preview volume in left column.
  12. Grabbed my files off that preview volume and copied them to the external drive.
  13. Praised everything good and right in the universe.
  14. Allowed DiskWarrior to complete the rebuild, which was successful and the repaired volume mounted when finished.

Hope this helps.

share|improve this answer
add comment

I tried everything as mentioned here, as I too had a similar problem, but had to go a bit further to fully solve my issue.

Problem:

I created an image of my disk using Disk Utility on Snow Leopard. Instead of making sure if the image was created correctly, I went ahead and reformatted the drive. Afterwards, I tried to mount the image but it wouldn't let me verify, scan for recovery and the CRC checksum was wrong. All that, just to remove a stubborn boot sector EFI partition that wouldn't go away. Total nightmare!

Solutions:

I tried creating a new checksum and disc scan for recovery. In some cases that helps, but not with this dmg as it was corrupted from the beginning.

What worked best for me was @simonair's answer; although it didn't mount the image completely, it at least allowed it to show the dmg as a "ghosted" active partition under disk utility as well as a working/retrievable partition disk7 under terminal.

Once it was finally visible, I used "Data Rescue 3" in "Advanced View" mode to also show the dmg for scanning. The simple view only shows internal and external physical drives, it seems.

Click on your name.dmg file/virtual drive and make it do a full scan. Depending on its size, it may take from seconds to hours (mine was over 450GB, took approx 6 hours for "deep scan").

I now have all my documents, projects, backed up software and Aperture photo library restored to the original drive after a whole day of suffering.

Moral of the story:

For important data, forget dmg's as they may backfire. If you must create a dmg, make sure it works before deleting the original data. A full 1:1 backup works best to optical media (CD/DVD/BD) or to an additional internal/external hard drive.

Observations:

Disk Drill and Stellar Phoenix didn't help as much as I thought they would. Data Rescue is worth the money, no contest!

share|improve this answer
add comment

I also had this problem. In the end, what worked for me was Data Rescue.

What didn't work

I tried to follow the recommendations above and copy the dmg to read/write format. I tried both Disk Utility convert and hdiutil command in the terminal, but in both cases Finder hang in the end of the process and I had to restart the computer (forced restart of Finder didn't help).

What worked

I tried to mount the image within Disk Utility. As said above, this doesn't work, but the image now shows up as a greyed-out name in the left column of Disk Utility. This step is necessary so that Data Rescue can see the broken disk image. Next, launch Data Rescue. With "Quick Scan", Data Rescue found the entire folder structure and I could choose what files to recover. All in all, this took only 2-3 minutes.

Thanks sozuke80 for the Data Rescue tip!

// Niklas

share|improve this answer
add comment

Have you repaired your disk permissions recently? This may help, since there may be some problems (permissions wise) on DiskUtility, or the part of the filesystem related to mounting of disk images.

Edit: Since that didn't work, I would next use OnyX and run all the maintenance options - this might just fix the problem.

It will also check your S.M.A.R.T status, telling you if you have a hard drive problem (and if you do, it's probably the cause of your issues).

share|improve this answer
    
Good thought. I repaired permissions but I'm still getting the same error. –  Peter Burns Aug 7 '09 at 19:26
    
OK, check out the edit :) –  EvilChookie Aug 7 '09 at 19:30
add comment

Have you rebooted? I've had some weirdness with DMG's before and a reboot cleared it up.

I know it sounds too simple, but sometimes the mounting plumbing can get whacked out.

share|improve this answer
    
Yep, I've rebooted, still no dice. –  Peter Burns Sep 2 '09 at 23:21
add comment

I ran into a similar situation. I had an image created by Disk Utility and every time I went to mount it, I got the no mountable file system error.

The solution was to convert the image to read/write type and then I was able to double click it to access its contents.

share|improve this answer
2  
And how do you convert the image to read/write? –  Alexander Stolz Aug 10 '12 at 8:24
    
@AlexanderStolz In "Disk Utility", select the xxx.dmg file, then click "Convert" on top menu, choose "read/write" instead of "compressed". I'm just converting it, not sure whether it will work or not.. –  Kjuly May 31 '13 at 11:30
add comment

I ran into a similar situation. I did what simonair suggested and I received a message in Terminal that Volume mounted successfully. However It did not help me access the mounted Volume neither was I able to confirm the mounted Volume. Nor was I able to mount the image using Disk Drill or even scan through. Nothing succeeded.

Here is what I did to solve my problem. I see that in this post some suggested that we should convert name.dmg to writable file. I used the command from Terminal to convert but was not successful. INSTEAD alternatively, I used Disk Utility, attached the Volume (yes I got the same message again, ''no mountable system files'' however, Disk Utility nevertheless attached the image, which I was able to do before anyways. This time, I selected it and then clicked New image, and then selected image format read/write, not the compressed option. I created a new image. This time this image was writable however, it still would not mount using Simonair's solution. However, this time I was able to scan it with Disk Drill with exact file locations and folder hierarchy as I had. Recovering all from thereon was a breeze. Just remember: when you create new image of an attached volume and chose not compressed but read/write, you need to have a disk with exact amount of space that totals the total space allocated within that name.dmg file (not the amount of space the data takes). Mine was huge, and luckily I had an external disk with enough space to do that and it took about 5 hours for about 400GB of disk allocation. Good luck.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.