Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an HP Media Vault mv2120 (Linux based, not WHS based) and sometimes when I go to delete files that I added to the server, I get a message telling me that I need permission from Unix User Nobody to delete them. Why is this happening and how can I prevent it? So far when it happens, I have to ssh into the server (which was not enabled by default and I had to do some digging on Google to find out how to enable it) and delete them from there.

share|improve this question
    
What distribution are you using? And is this a file already on it, or something you have just copied and loosing permission? - I got this a few times with my nas when I transfer files with large file names. To solve this, I either rename or delete using a web interface or ssh. –  William Hilsum Aug 7 '09 at 6:57
    
When I login I get the message: BusyBox v1.01 (2008.02.08-22:41+0000) –  jasonh Aug 7 '09 at 17:26

1 Answer 1

up vote 2 down vote accepted

It sounds like you'll need to take ownership of the files with chown and possibly set permissions on the file(s) to 777 with chmod

Since your server is linux based, you should be able to get the correct syntax with the man command.

share|improve this answer
    
Oh I was afraid of that. That's what I was doing, but I was hoping for a way to prevent this from happening. –  jasonh Aug 7 '09 at 17:27
    
Try setting the parent folder's ownership and permissions - that way, subsequent files that you place in that folder will inherit the parent's permissions. –  EvilChookie Aug 7 '09 at 19:16
    
I'll have to give that another shot. –  jasonh Aug 8 '09 at 19:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.