Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The other day I was forced by the aftermath of a failed software installation to reinstall Windows 7on my iMac. All went well except that I am unable to use the internet on that box now because for whatever reason the two devices are not communicating properly.

I have a cable connection and my ISP does not use DHCP so the box is staticlly configured and I have verified with my ISP that the current configuration is correct.

Symptoms

  1. The ARP entry mapped to the default gateway IP address is ff-ff-ff-ff-ff which I don't think is the MAC address of any interface on my box, or the modem
  2. Pings fail with a mix of timeouts and "Destination host unreachable" replys from my boxes staticly assigned public IP
  3. Windows networking reports "No network access" and Network Diagostics can offer no assistance.

My ISP believe this to be a problem with the NIC on the Mac, however I disagree because when the Mac is connected to another computer, ping and name resolution is successful between both hosts.

I did try creating a static ARP mapping between the MAC that my working laptop associates with the default gateway IP, this did not help

I'm officially stumped so any suggestions are welcome.

share|improve this question
    
Are you hooking the modem directly into your machine, or do you have a router? From the sounds of it, you're hooking it up directly. Some ISPs will register the MAC address of the computer hooked up to the modem, which is why in routers you see an option to clone a MAC address. Was the modem set up initially with your other machine? –  Xanny Sep 30 '10 at 11:30
    
The modem was set up originally with the iMac –  Crippledsmurf Sep 30 '10 at 12:09

2 Answers 2

up vote 0 down vote accepted

I solved this by setting the iMac to spoof the MAC of my laptop. To be honnest, I'm not quite sure why that worked since as I noted i the comments the modem was originally setup with the iMac and no hardware changes have occured.

In case this helps someone else, to change my MAC address I went to Network and Sharing Center > Change Adapter Settings > Configure > Advanced Tab > choose "Network Address" from the left list box. I understand this sccreen is driver-specific but this may help people who have late 09 iMac's or NVIDIA cards

I must give credit where credit is due and thank Fowl2 for helping me fix this even though he did not post an answer to this question his help via other channels was much appreciated

share|improve this answer
    
It sounds like you are running Windows 7 exclusively. Have you tried to connect to the internet while you were running OS X? –  lajuette Sep 30 '10 at 12:20
    
No i haven't, I don't even have it installed –  Crippledsmurf Oct 1 '10 at 8:22

The best solution to this problem is to reboot the cable modem any time you change what device you have directly connected to it.

The reason why this works is that your ISP will normally (read: always) configure your cable modem so that it will only bridge traffic for one device. The first MAC address it sees is the one it will bridge for. If you remove that first device and replace it with one with a different MAC address, the modem considers this as if it's being asked to bridge for TWO devices now. Just reboot it to clear its internal list of what MAC addresses it's bridging for.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.