Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I use ctrl+mouse, or use the scroller to click a link. I got two or three new Internet Explorer tabs open, does anyone know how to fix this. It happens on my Chrome too. My lap top is Windows 7 64-bit.

Also, how can I restore the Internet Explorer 8 on Windows 7?

share|improve this question

migrated from stackoverflow.com Sep 30 '10 at 16:20

This question came from our site for professional and enthusiast programmers.

    
Your question is more appropriate for superuser. –  user49706 Sep 30 '10 at 16:03
1  
Are you sure your mouse isn't just touchy? And what do you mean by 'restore the IE8'? –  Shinrai Sep 30 '10 at 16:47
    
You should upgrade to IE9. It is substantially more user friendly and prevents third-party applications and add-ons from causing this type of problem. –  Paxamime May 30 '11 at 4:46
add comment

1 Answer 1

couple things to check in IE Tools>Internet Options. alt text

make sure you only see one site for your home page. then press the settings button alt text

checking "Open only the first home page when Internet Explorer starts" will suppress duplicate tabs. But look at all of these and how they impact your experience. alt text

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.