Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

With Firefox 3.6.10 on Windows XP (I haven't tried other combinations), it seems like some websites prevent visitors from saving their password. That happens a lot with bank websites (for obvious security reasons), but I'm also experiencing that with myopenid.com and others.

Is there a way to force Firefox to remember passwords for ALL sites?

I have tried many tricks found on the web, but none of them work in all cases.

One of these tricks was to run a Javascript in order to remove the autocomplete="off" property from the password field, which seems to help in some cases, but not all.

Another trick is to modify some Firefox configuration file, but again some websites are resistant to that. One such website is myopenid.com.

Please note that this is not a duplicate of Firefox: Remember new passwords without prompting. Here I'm asking for a tweak that will save passwords for the sites that don't let users save them.

Note: Now I'm getting confused because it's working again. I have disabled all addons and it's saving the passwords again on myopenid.com. I think the Javascript solution proposed below is OK but I have another one I like better, I will post it too.

share|improve this question
    
possible duplicate of Firefox: Remember new passwords without prompting –  r0ca Sep 30 '10 at 20:43
3  
This is not a duplicate, I'm not asking Firefox to automatically say yes to remember my passwords. I want to have that function on ALL sites, because on some sites this option is not proposed. Try myopenid.com –  md1337 Sep 30 '10 at 21:08
    
You must be doing something wrong. FF remembers my password on myopenid. (and I have done nothing special) –  Nifle Sep 30 '10 at 22:01
    
@Nifle: Please state your version of Firefox (and Operating system). Also, md1337 should state his. –  Dan Sep 30 '10 at 22:15
    
64bit win7 and FF 3.6.10 –  Nifle Oct 1 '10 at 7:56
show 1 more comment

5 Answers

Lastpass has a special function for unwieldy password fields.

  1. Go to the log-in page that bothers you.
  2. Fill in name and password, but don't press enter, don't log in yet!
  3. Click on the Lastpass icon in the Navation toolbar, or anywhere - just not in the context menu.
  4. Click "save all entered data", then do as you normally do when saving a password.

This works nearly all the time for me.

share|improve this answer
add comment

You might want to look at an external password manager as a solution that has a Firefox plugin.

1Password - Mac, Windows, iPhone, and iPad support. This is the solutions I use. Great for keeping track of website passwords and other sensitive information. Combine with Dropbox for simple syncing across multiple machines.

Lastpass also works really well. I used it for awhile before moving to 1Password.

share|improve this answer
add comment

OK so here is another answer I think is more convenient that the Javascript one.

First go to your Firefox components folder, by default in my case it's "C:\Program Files\Mozilla Firefox\components"

Now open the file nsLoginManager.js

Go to the function at around line 804 (varies with version of Firefox), that reads:

/*
 * _isAutoCompleteDisabled
 *
 * Returns true if the page requests autocomplete be disabled for the
 * specified form input.
 */
_isAutocompleteDisabled :  function (element) {
    if (element && element.hasAttribute("autocomplete") &&
        element.getAttribute("autocomplete").toLowerCase() == "off")
        return true;

    return false;
},

Now comment out the first 3 lines, so it ends up like this:

/*
 * _isAutoCompleteDisabled
 *
 * Returns true if the page requests autocomplete be disabled for the
 * specified form input.
 */
_isAutocompleteDisabled :  function (element) {
    /*if (element && element.hasAttribute("autocomplete") &&
        element.getAttribute("autocomplete").toLowerCase() == "off")
        return true;*/

    return false;
},

Save it, restart Firefox and you should be good to go...

share|improve this answer
    
Nice solution & it works for good. +1. –  Mehper C. Palavuzlar Dec 17 '10 at 7:51
add comment

The following tweak is what you need. I've been using it for a long time and it's saved me a lot of time.

Tweak Firefox’s Password Saver Without An Extension:

  1. Bookmark the link on the above page referred to as Password Saver. To bookmark the link just right-click on it and select "Bookmark This Link...". (It's a Java script. I cannot link it here because of html-editing limitations.)
  2. The next time you find a site that won't remember your password just click on the bookmark. It will then remove all instances of autocomplete="off".
  3. Type your username and password into the site and press submit.
  4. That's all! You should now be prompted to let Firefox remember your password.

Screeny:

alt text

share|improve this answer
    
I'm aware of this and I have tried it before. It doesn't work in all cases. See my edited question for details. –  md1337 Oct 1 '10 at 13:18
    
You say "many tricks" but you don't say what they are. If you state them clearly in your question, you can increase your probability to have the right solution. –  Mehper C. Palavuzlar Oct 1 '10 at 13:24
    
I was editing while you were typing your comment, check again. I will post a screenshot too in a minute. –  md1337 Oct 1 '10 at 13:26
    
OK then, let's see if Super Users can solve this. –  Mehper C. Palavuzlar Oct 1 '10 at 13:28
    
I have to apologize, it appears it's working again, see my edited question and my answer to myself. –  md1337 Oct 1 '10 at 13:39
add comment

It doesn't let you remember on some sites? Must be that you accidentally said "Don't Remember" for some of your sites. Go into options and find the list of sites for which it should never remember your password and then delete anything for which it says to never remember your password for.

share|improve this answer
    
Nope, that list is empty. Have you tried the myopenid.com example? –  md1337 Sep 30 '10 at 21:07
    
myopenid.com password element is: <input id="password" type="password" name="password" tabindex="2"> I don't know any html, but that seems right to me... Firefox probably uses type to know which fields are passwords, so don't know why it wouldn't be picking it up. –  Dan Sep 30 '10 at 21:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.