Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

since last sunday I've got a problem with my PC after I connected an external HDD.

After connecting everything was fine, I copied things on the HDD and from the HDD to my PC. On my setup: I've got 2 physical drives, one has 120GB (this is where my Windows 7 is installed) on drive-letter C and a 1TB-drive for everything else (drive-letter D).

In the middle of the copy-action a bluescreen popped up and didn't stay for a second so I can't say what there was postes in the errormessage. At this point I was just concerned about the files I just tried to copy, I didn't know that this would be my smallest problem.

After the restart I got the following error "DISK BOOT FAILURE. INSERT SYSTEM DISK AND PRESS ENTER". You don't like it when that happens. After I found my system disk and inserted it: Nothing. I tried to boot with and without the external hard drive, always the same error.

I then tried to fix my MBR with the recovery console, this helped nothing. But I found out, that my Windows now hat the drive-letter E and not C anymore. C now was the system-reserved partition. After googling I found out, how to assign new drive-letters with the recovery console, so I did:

diskpart
list volume
select volume *
assign letter=C

I restarted and: it worked!! Everything was fine like nothing ever happened. But then I restarted. And I got the DISK BOOT FAILURE again. I tried the same thing with diskpart like before since I needed some data from my D-drive and hat no live-disk at hand. But this time, it didn't help. Same error. Since I need my PC I formatted my C-drive and installed Win7 again. Since all my data is on another drive, this is not that big problem for me. Install was successful, everything went fine. But then I restarted. Same error again.

Alright, and now I have no clue, how the solve this problem. Can anybody help me?

share|improve this question
add comment

1 Answer 1

It sounds like it may be trying to boot off that external drive... Check your boot options in your BIOS to ensure USB HDDs aren't placed at the top of the HDD list when plugged in.

Additional info since being reminded that he said he tried it without the drive plugged in:

Knowing this now, I doubt the external HDD or boot options has anything to do with your problem, and it sounds more like that, as you were putting new files onto one of the internal drives from the external drive, you hit a previously unused spot that is damaged, or it just caused enough stress to the drive that produced a now-permanent fault.

Determine the make/model of the internal drive(s), and go to the manufacturers' website for some diagnostics utilities for that drive model.

I'd suspect the internal drive you were copying to/from at the time of the blue screen.

Additionally, blue screen errors very rarely pop up and then go away, especially without leaving evidence in the Event Logs. Did/do the event logs show any errors (Disk, Disk controller, or NTFS errors perhaps)?

share|improve this answer
    
Except Tim says he tried booting with the external drive unplugged. –  CarlF Oct 1 '10 at 12:24
    
Correct, as said, I tried it with booting without and with the drive. Boths not working. I also checked my boot options, the error comes clearly from my local hdd since I tried changing the boot options and the error always appears when it's trying to boot from my hdd. –  Tim Oct 1 '10 at 12:42
    
Your right, I missed that bit.. I'll add some ideas to my answer.. –  Ƭᴇcʜιᴇ007 Oct 2 '10 at 19:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.