Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Recently we switched from DSL to Cable. We have the battery backed-up modem that stays powered on after having power disconnected.

I've setup our WRT54G router with this modem back to its original configuration that worked fine under DSL.

  • Changed subnet to 192.168.2
  • Changed ssid
  • Enabled WEP
  • Change admin p/w

After setting everything up, all PCs/devices in the home appear to work fine.

On a power outage at the router, however, things start to go haywire. Nothing can get past the router for Internet access. I've confirmed that by plugging directly into the modem, I will get Internet access. Also, devices appear to obtain an IP address from the WRT54G. I can browse to the router's settings page without a problem. I've tried renewing the routers DHCP lease with the modem. This has no effect. I've renewed DHCP from the PC trying to gain Internet access-- again no effect.

The only thing that has an impact is resetting to factory defaults and rebuilding the exact same config from scratch. Then everything magically starts working. This is rather annoying as we do lose power somewhat frequently.

Before I reset to factory defaults and reset the configuration, one thing I did was save off the current, seemingly broken, configuration. I reset to defaults and reconnect-- I can get Internet through the router. However once use the config file I saved off, everything stops working again.

At first glance maybe the router's configuration became corrupt and this is reflected in the config file that I saved off?

Has anyone else experienced similar problems? Is it possible that a power loss would corrupt the router's configuration this way?

Firmware Version Linksys Ver.4.21.1

share|improve this question
Possibly related (but I don't consider a dupe necessarily)… – Doug T. Oct 1 '10 at 14:15
wrt54g, which version? These are perfect for dd-wrt or tomato firmware. Which one may help and two will give you many more features you may be interested in! The reason I ask which version is I believe the newer versions has smaller flash or whatever and you can only install the micro/mini dd-wrt. I have a v2 and a v6, the v2 took standard dd-wrt, v6 required smaller version with limited feature set. – Chris Oct 11 '10 at 0:26
wrt54g v4.0. I ended up getting an N router. Another excuse to get some more tech to play with. The Wrt54g will likely go to a friend, I'll pass on the dd-wrt recommendation. – Doug T. Oct 11 '10 at 0:29

Yes. This sort of thing happens all the time. I'm a maintenance tech at a factory and seems like every power outage brings on something like this. Though, sometimes its worse than just losing the data. Every time it happens we spend probably $3-4 on parts that have to be replaced--not to mention the labor cost. Power spikes can be devastating to poorly guarded circuitry. That's why most IT departments have their servers on UPS systems.

UPS's are great if you can afford them. Did you have one of those handy dandy power strips with the built in circuit protection?

share|improve this answer
well everything was surge protected and this router has been working fine for years with dsl. – Doug T. Oct 1 '10 at 14:23
UPS's are superior to surge protection. Surge protectors can't protect against dips (loss)--just spikes. – Flotsam N. Jetsam Oct 1 '10 at 14:36

What firmware are you running on the Router? WRT54G routers have many options available.

OpenWRT doesn't use NVRAM since Kamikaze - it's all file based, with a special backup-recovery mode you can boot to if you biff your config. (Caveat: read the manual on how that backup mode works BEFORE you need it.)

share|improve this answer
update question with firmware version – Doug T. Oct 1 '10 at 21:55
I'm unable to speak to stock Linksys firmware, sorry. There's a reason why 3rd party firmwares are popular. – Broam Oct 4 '10 at 17:52
I do not understand your comment. – Chris Oct 11 '10 at 0:27
s/speak to/speak about/ – Broam Oct 11 '10 at 14:53
up vote 0 down vote accepted

The problem seems to stem from the cable modem's (or comcast's) refusal to renew/grant the router's DHCP lease unless the cable modem has been reset. Since the cable modem is battery backed up, it did not lose power with the router. A manual cable modem reset is required and appears to resolve the issue.

Still unclear why building the router's config up from scratch seems to have an effect.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.