Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This started recently and I can't really see exactly what it's doing or how it could be doing it. I checked Accessibility Options in Windows but these are off.

When I type this command (while ssh-ed into a remote server) and then tab to auto-complete, I get weird results:

cd /mnt-sh: <( compgen -d -- '/mnt' ): No such file or directory

I want to tab to get options for directories in /mnt but this thing happens. I Googled the result to no avail.

This only happens when ssh-ed in. The Cygwin terminal works fine locally.

Any ideas?

share|improve this question
    
Perhaps your $TERM is set to something odd in the remote shell? –  Nifle Oct 1 '10 at 16:54
add comment

1 Answer

up vote 4 down vote accepted

So I edited ~/.bashrc and removed the end lines regarding bash_completion. Restarted the session and it was back to normal.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.