Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Vim 7.3 on my Ubuntu machine, and unicode was not compiled in by default. What's the configuration option to enable unicode when you compile vim 7.3? I've searched their website and the internet, and I can't find it for the life of me. That said, it's probably right underneath my nose.

share|improve this question
1  
How exactly did you install it? I can't imagine how this could have come to pass unless it was done deliberately. –  frabjous Oct 1 '10 at 21:14
    
Just your standard config / make / make install. It may not be VIMs fault, but unicode works on gnome-terminal, and displays as gibberish when I copy-paste to VIM. The same was not true for 7.2, which is why I assumed it was VIM. –  So8res Oct 2 '10 at 18:15
    
Sounds like you just aren't using a unicode font to display the text, which means it's not vim's fault, but the font you're using. –  frabjous Oct 8 '10 at 16:10

4 Answers 4

The first thing to do is to check the output of the ":version" command and look for "multi_byte". It should be preceded by a + if it is included, and a - if it is not. "multi_lang" is also important, but to a slightly lesser degree. Alternatively you can do:

:echo has('multi_byte') has('multi_lang')

And Vim will print "1"s to indiciate the features are included, or "0"s otherwise.

If those are included then you need to make sure Vim is set up properly. The first thing to try is to put ":set encoding=utf-8" in your ~/.vimrc.

If that doesn't work and you're using Vim in a terminal (in other words, not gVim), start Vim and type ":set termencoding?". If your system language settings are properly configured for unicode/utf-8 it should either be empty ("termencoding=") or set to utf-8 ("termencoding=utf-8").

It would probably be a good idea to look at ":help mbyte.txt" and possibly ":help usr_45".

share|improve this answer

It is --enable-multibyte.

share|improve this answer

You might have had set encoding=utf-8 in your system-wide vimrc that isn't being used when you manually compiled. Try adding that to your $MYVIMRC. See :help unicode for more information.

share|improve this answer

Unicode is enabled by default!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.