Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to connect to several Cisco VPN networks using the OS X built-in VPN utility and I'm receiving an error. I have several isolated networks I connect to and they have all been working flawlessly since Snow Leopard was released. I also have 3+ co-workers who use the same settings and are not experiencing any issues.

This is the system error I receive when I try to connect:

VPN Connection

A configuration error occurred. Verify your settings and try reconnecting.

This is the limited information from the system.log:

Oct  1 17:36:27 Computer-Name racoon[686]: Connecting.
Oct  1 17:36:27 Computer-Name racoon[686]: IKE Packet: transmit failed. (Initiator, Aggressive-Mode Message 1).
Oct  1 17:36:27 Computer-Name racoon[686]: Disconnecting. (Connection tried to negotiate for, 0.010253 seconds).
Oct  1 17:36:27 Computer-Name racoon[686]: IKE Packets Transmit Failure-Rate Statistic. (Failure-Rate = 100.000).
Oct  1 17:36:37 Computer-Name configd[13]: SCNCController: Disconnecting. (Connection tried to negotiate for, 0 seconds).

I've been asking google and super user for help for a couple hours now, but all the solutions and issues I've found have to do with loosing an existing connection, or at least have some IKE Packet transmit successes. My system isn't even getting a chance to try to use the configuration settings (password, group, shared key, etc) I have defined. I tried to re-create the connections with the known credentials and it is still failing.

I tried repairing the file permissions with Disk Utility and I get the same errors.

I'm running the 32-bit version of OS X and I can not think of any system changes that have occurred that would affect the VPN functionality.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

I had the very same issue:

It works on one system with 10.6.5, and with the same credentials, on a second 10.6.5 system I get this error.

I then discovered that on one system, another racoon daemon was running (in this case IPSecuritas) Turning this off made the internal client work.

share|improve this answer
    
That was exactly my problem. For one reason or another, IPSecuritas began loading on boot-up so I wasn't expecting to have to shut it down to get on my other VPNs. I felt dumb when I finally figured it out, but glad to be rid of the error. Thanks for chiming in with the answer. –  Tyler Dec 18 '10 at 4:15

This occasionally occurs for me as well, e.g. when I switch between two different Cisco VPNs. It seems to be a minor crash in racoon somewhere*. Manually restarting the process seems to do the trick for me:

~ :➜ ps -ef | grep racoon
0  5861     1   0   0:00.09 ??         0:00.15 /usr/sbin/racoon
~ :➜ sudo kill 5861
~ :➜ ps ax | grep racoon
<wait until it shuts down. sometimes you may need to SIGKILL it (kill -9 <pid>)>
~ :➜ sudo /usr/sbin/racoon
~ :➜ ps -ef | grep racoon
0  6786     1   0   0:00.08 ??         0:00.15 /usr/sbin/racoon -x

(Don't know what the '-x' param does, it's not mentioned in the man page)

(*) Haven't investigated

share|improve this answer
    
killing racoon was enough for me. It restarted automatically (via launchd I assume). I did not need to run 'sudo /usr/sbin/racoon'. I am on 10.6.7. –  Frank Szczerba May 17 '11 at 13:39

You can try stopping and restarting the racoon launch agent:

launchctl stop com.apple.racoon && launchctl start com.apple.racoon
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.