Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ubuntu 10.10 i386 (beta), Dell n500 notebook

Several times a day my keyboard layout starts randomly switching back and forth all by itself. Scroll lock indicator blinks like a crazy.

Rebooting helps. In text console (CTRL+ALT+F1) all is OK.

Update: sometimes the problem goes away all by itself after some time.

Update: logging out and back in also helps. Perhaps there is some process that I could kill / restart manually?

Please help me to diagnose the problem.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

Gotcha!

Killing gnome-settings-daemon solves the problem.

share|improve this answer
    
Well done for finding a workaround, but that's hardly a fix: gnome-settings-daemon is supposed to keep running as long as you're logged in. This is probably a bug in gnome-settings-daemon; I recommend that you report it to the Ubuntu project. –  Gilles Oct 4 '10 at 17:14
    
It is a known bug: bugs.launchpad.net/gnome-settings-daemon/+bug/625793 (Finally a bug submission system that makes sense.) –  Alexander Gladysh Oct 4 '10 at 18:23
add comment

(I only have 10.04 here, hopefully this hasn't changed too much.)

Switching between layouts with ScrollLock indicating the layout is a supported configuration. It's set in System / Preferences / Keyboard / Layouts. You can set up multiple layouts and select a checkbox to use different layouts in different windows. In the Options child dialog, there is an option to “Use keyboard LED to show alternative layout”.

As to what is triggering a change, it could be when you change windows (if you have that option enabled), or it could be when you press a key (look under “Key(s) to change layout” in the Options dialog).

If it's neither of these and you do have per-window layout, there might be a window gaining focus and immediately losing it. When the problem occurs, try looking in the system monitor for active applications that might be doing this, or type wmctrl -l in a command line and check if every line corresponds to something you expected (ask here if you have doubts as some window titles may not be self-explanatory).

share|improve this answer
    
Yes, I have two supported layouts (US and Russian), option to "Use LED..." is enabled and I have separate layouts for separate windows enabled as well. –  Alexander Gladysh Oct 2 '10 at 14:17
    
However, I doubt that it is window focus change (will check though), because, when this issue happens (all by itself!), I can type into any editbox without any kind of interruption from the system and layout changes randomly as I type. –  Alexander Gladysh Oct 2 '10 at 14:19
    
Checked. Nothing weird there. Any other ideas? –  Alexander Gladysh Oct 4 '10 at 9:48
    
I've updated my question a bit –  Alexander Gladysh Oct 4 '10 at 10:32
add comment

I had the same problem for months. Result: By default, in the extremely well-hidden great-great-grand-child-sub-sub-dialogue:

System Settings / Keyboard / Typing / Layouts / Options... / Keys to change layout

the check box "Shift+Caps Lock" was enabled so that every time your pinkie presses both left shift and caps lock, conveniently next to each other, the key layout gets scrambled.

Thanks Gilles for helping me solve this. I was going mad!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.