Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm tearing my hair out on this one. Basically I need IPv6 to work on a Windows 7 (Home Premium) Dell laptop and it isn't.

I have the wireless networking all working but if I click on the wireless network and select status it says:

IPv6 Connectivity: No network access

I have the firewall completely disabled, the registry setting DisabledComponents is set to 0 (for IPv6) and I can only find answers of Google that go something like:

  • reset the TCP/IP stack (done that, no effect);
  • you don't need IPv6 (yes I do)

IPv6 is enabled in the properties for my wireless adapter. God I hate Windows. Anyone have a solution for this?

Annoyingly I had a similar problem to this a few weeks ago and I ended up running a command that removed a firewall rule and that solved it even though my firewall was disabled so there's something strange going on here. I really need a solution before I go nuts.

Edit: no other Windows 7/Vista machines on this network. I'm actually trying to talk to an Airport Express, which uses IPv6 for AirTunes and configuration. Works seamlessly on my Macbook Pro on the same network. Windows 7 doesn't see it nor can it see the extra speakers in iTunes. Non-functioning IPv6 seems to be the cause but I can't find out why IPv6 isn't working.

Edit 2: I should also point out I have a link-local IPv6 address (ie fe80::/10) on the wireless interface. Also, IPv6 works over ethernet but not wireless!!! I don't understand this. Below is the output from running ipconfig /all.

Notice that wireless has DHCPv6 and other things on it and the ethernet doesn't. So I guess I need to make the wireless like the ethernet somehow? Windows IP Configuration

   Host Name . . . . . . . . . . . . : laptop
   Primary DNS Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom Virtual Wireless Adapter
   Physical Address. . . . . . . . . : 1C-65-9D-0B-E4-7F
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : DW1501 Wireless-N WLAN Half-Mini Card
   Physical Address. . . . . . . . . : 1C-65-9D-0B-E4-7F
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::598:e33c:9cc7:b542%12(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.104(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Sunday, 3 October 2010 10:11:17 AM
   Lease Expires . . . . . . . . . . : Wednesday, 6 October 2010 10:11:17 AM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 219964829
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-08-Firefox-C3-F0-4D-A2-7B-63-00
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek PCIe FE Family Controller
   Physical Address. . . . . . . . . : F0-4D-A2-7B-63-00
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::a8a6:9367:8182:fa68%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.1.111(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : Sunday, 3 October 2010 11:39:15 AM
   Lease Expires . . . . . . . . . . : Wednesday, 6 October 2010 11:39:15 AM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.1
   DHCPv6 IAID . . . . . . . . . . . : 250629538
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-08-Firefox-C3-F0-4D-A2-7B-63-00
   DNS Servers . . . . . . . . . . . : 192.168.1.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter iSATAp.{1533D0AA-42AB-4904-B22E-EEF6054E76C3}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter iSATAp.{D60E2DFB-D336-4A54-B77C-979A6B5A7F05}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter iSATAp.{E66DCB54-E7A4-41B9-ADEE-86284F92EEF1}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
share|improve this question
    
I have never had a problem regarding this and a firewall, but I possibly know what is going on, do you have any other Windows 7 or Vista machines on your network? –  William Hilsum Oct 2 '10 at 16:12
    
@Wil no other Win7/Vista machines. –  cletus Oct 2 '10 at 23:43
    
I just tested something. Plugged it in via ethernet and IPv6 works perfectly. It only doesn't work over wireless! What gives? I did have McAfee Firewall installed (Dell shovelware that came with it, not much choice). It's gone now but it's left some stuff around I think. Like to get ICMP working I had to remove a firewall rule from a firewall that was allegedly disabled. –  cletus Oct 3 '10 at 3:28

7 Answers 7

up vote 2 down vote accepted
+50

I found a solution to this:

  1. Start the Airport Utility;
  2. Select the Airport Express;
  3. Click "Advanced";
  4. Select IPv6;
  5. Change IPv6 mode to "Tunnel";
  6. Check "Block incoming IPv6 connections";
  7. Configure IPv6 automatically.

Restart and suddenly Windows 7 can see it. OSX could see it regardless but can still see it.

Don't ask me why but this fixed it.

share|improve this answer
    
Have you tried the Microsoft 6to4 Adapter? –  harrymc Oct 12 '10 at 8:37
    
@harrymc the 6to4 adapter is for external IPv6 is it not? –  cletus Oct 14 '10 at 4:33
    
As far as I understand, it was supposed to let ipv6 talk to ipv4. The details are not clear, and it could also be just the opposite direction of what you ask, but it would be interesting to see what it does in your configuration. –  harrymc Oct 14 '10 at 4:52
1  
@harrymc thanks for your input but I believe 6to4 is for tunnelling between IPv6 networks over an IPv4 network. I have a vague memory of an RFC about transporting IPv6 pockets over IPv4 or something similar. Anyway, check this answer. A solution has finally been found. –  cletus Oct 14 '10 at 4:59

The local network / internet access is complicated.

Based on your comments, I think the reason you are seeing the message you are seeing is because there are no other Windows Vista or Windows 7 machines on your network (or any other machines designed for link local IPv6).

These are the possible states:

No network access - No DHCP server, no link-local address assigned.

Limited network (or similar) - No DHCP, link-local address assigned.

No Internet - DHCP detected, no access to internet

Internet - DHCP detected, Internet access available.

Link Local addresses are purely used in an ad-hoc way for computers to network without a network infrastructure. The only way I know of to make it work is to either have an IPv6 enabled DHCP server, use other link-local compatible devices or manually assigning an IPv6 address.

In addition, to rule out anything silly / restrictions on your machine (I have seen a few drivers cause this), you can check it hasn't been disabled in your registry:

Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\ and look for an entry called DisabledComponents and make sure it is a 32-bit Dword and set to 0. If you do not see it, try creating it in order to reset restrictions, then restart your computer.

share|improve this answer
    
Thanks for your answer but as I mentioned in the question, DisabledComponents is already set to 0. Also, I'm connecting to the network created by the Airport Express. My Macbook Pro does this fine so is getting an IPv6 address from the Airport Express. It's Windows 7 that isn't working. –  cletus Oct 3 '10 at 1:36
    
@Cletus sorry... that disabledcomponents was an extra bit and forgot you wrote that... Never dealt with this situation personally, but if IPv6 DHCP is not working, I would personally (as part of diagnosing) try to disable IPv4 on the network card and see if that kick starts IPv6. Next, (I know not perfect) what happens if you manually assign an IPv6 address within the same range? ... And from your original question, don't hate Windows! It has many positives! –  William Hilsum Oct 3 '10 at 2:01

Your currect Windows IP Configuration shows both connections simultaneously, so...

Pull out the network cable and see if the wireless does connect then.

Really sounds dumb, so hit me if I misread something...


Update 1.

Can you try the following three commands with the wired connection disabled and update your question:

netsh interface ipv6 show addresses

netsh interface ipv6 show interfaces

netsh interface ipv6 show subinterfaces

Are you sure that this is enabled (and the properties configured right):

alt text

share|improve this answer
    
I've worked out that some settings are per interface and some are protocol based. Like DHCPv6 shows up under both wireless and ethernet when the ethernet cable is plugged in but will disappear from both if it is removed. I need IPv6 to work when only wireless is being used. –  cletus Oct 9 '10 at 13:26
    
Added an update. –  Tom Wijsman Oct 9 '10 at 14:43

Many wireless routers automatically block all contact between wireless units.

Something to verify:

Check if "Client Isolation" is turned on in the wireless router (if it has this option).
This option is also sometimes called "AP isolation" or "Privacy Separator".

share|improve this answer
    
The wireless ADSL router has an isolation setting but it's off. It's also not part of this equation. I'm trying to connect to the wireless network created by the Airport Express so the router's wireless settings shouldn't be (afaik) relevant. As far as I can see the Airport Express has no such wireless isolation setting. –  cletus Oct 10 '10 at 13:14
    
Have a look at this discussion : forums.cnet.com/7723-13973_102-339365.html. Airport Express did finally work there with ipv6 for some people, but there are too many suggestions to duplicate here. –  harrymc Oct 10 '10 at 13:36

Sounds like it could be a bug in the driver for your wireless card. Make sure it's up to date. If it's already up to date, it could be a regression and you can actually try an older driver. Since IPv6 just isn't used much at all on the desktop in the PC world, a lot of manufacturers haven't done the testing they need to in this area. Even macs have had some trouble.

share|improve this answer

i've been having similar issue. but many threads on the web seem to claim that IP6 only works on a LAN and not a WLAN. hope i'm wrong because then I could get higher speeds. at the moment limited to 54mbs when router is providing 300mbs

share|improve this answer
    
Welcome to Super User! This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  Peachy Oct 10 '12 at 17:25

The article Windows 7 and IPv6: Useful at Last? :

The root of this is that Windows 7 handles IPv6 auto-configuration with the Neighbor Discovery Protocol (NDP) in a manner that’s not quite the same as how the RFC standards prescribes them. You can get around this by disabling Microsoft’s take on how IPv6 addresses are assigned with the command:

netsh interface ipv6 set global randomizeidentifiers=disabled

If this doesn't help, you might play around with the Microsoft 6to4 Adapter, which will let you use ipv4 over an ipv6 network:

In Device Manager, Action –> Add Legacy Hardware –> Next –> Install the hardware that I manually select from a list –> Network adapters –> Microsoft –> Microsoft 6to4 Adapter –> Next –> Finish the wizard.

From Configuring and Deploying IPv6 on Windows Vista

6to4 is a technology that assigns addresses and automatically configures tunnels between routers to provide unicast IPv6 connectivity between IPv6-capable sites and hosts across the IPv4 Internet.

Note : 6to4 only works with Public addresses.

In general, 6to4 routers are used to allow IPv6 clients to communicate with each other by using IPv6 over the IPv4 Internet. 6to4 routers require a public IPv4 address. Like ISATAP, the application data and IPv6 header are encapsulated in an IPv4 header to traverse the IPv4 Internet.

Unfortunately, I don't have the right environment for testing all this.

share|improve this answer
    
I've tried running this command. It doesn't solve the problem unfortunately. IPv6 only works when Ethernet is plugged in. –  cletus Oct 6 '10 at 1:18
    
Added some info that seems relevant. –  harrymc Oct 6 '10 at 8:31

protected by Community Oct 28 '12 at 8:26

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.