Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had to install the sane drivers with git due to my CanoScan 8800F to recognize the scanner. Scanning with "scanimage" works like a charm. But I'd prefer xsane to have a GUI. The problem is to install xsane without libsane dependencies. Otherwise it would install libsane and overwrite the git compiled sane-drivers. My scanner would not work then anymore. So I tried to install xsane by hand. But this seems to be a pain in the ass. First of all I downloaded the tar.gz sources (because there was no fitting version 0.996 as deb package). Secondly I tried to compile but I wasn't able to do a "make" because "SANE_CAP_ALWAYS_SETTABLE" wasn't defined in the code so it lead to a compile error. Then I found a patch but the patch didn't work either (Hunk #1 failed at ...**). After that I corrected the code by myself (I looked into the created "difference" file created by the patch command and looked for what I have to edit). "make" was able to compile then. When I was finished I created a deb package with "checkinstall -D make". At the end I installed the deb package with dpkg -i, but there doesn't seem to be any executable in /usr/bin or anywhere else, argh.

All I want to do is installing xsane without the dependencies of libsane (because I already have them, but apt doesn't know it). Is that anyhow possible?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

apt-get source xsane then tweak the dependencies in the debian folder. and rebuild the .deb

this will fix the issue but you should also change the version to crazy high so upgrades don't blow out your git install later.

share|improve this answer
    
alternately you could make an empty libsane package –  hbdgaf Oct 2 '10 at 15:58
    
Where do I get a dep with apt-get source xsane? I already tried that but I get tar.gz files. –  Bevor Oct 2 '10 at 16:28
    
go to an empty folder and do it, it generates the tar.gz stuff and a folder. go into the folder and look for the debian dir.(if it doesn't create the dir you have to extract the tar.gz) –  hbdgaf Oct 2 '10 at 16:44
    
Now I know what you mean. xsane can start now but now it can't access the scanner although it is recognized. This is getting really annoying. However, questions is answered. –  Bevor Oct 2 '10 at 17:03
    
By the way: Creating a rule /etc/udev/rules.d/50-libsane.rules with the content (in my case) #Canon 8800F SYSFS{idVendor}=="04a9",SYSFS{idProduct}=="1901",MODE="0666",GROUP="users" ..does the job. –  Bevor Oct 2 '10 at 17:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.