Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Setting up a brand new Dell Optiplex 980 with Windows XP SP3, and everything started up fine on the first boot. My first task was to install system updates, including IE8 and WGA.

After the required reboot after installing updates, I now get this error message:

Explorer.EXE Ordinal not found.

The ordinal 423 could not be located in the dynamic link library urlmon.dll

Per my cursory Google search, this forum thread places the blame squarely on IE8. The solution provided is to enter safe mode and remove IE8. Unfortunately, when I press F8 to choose to boot safe mode, I only have the option of "Windows XP SP3 Professional" and no safe mode options. Any other ideas? Thanks in advance.

FYI, I can get to the Windows Task Manager by holding down Control-Alt-Delete, but programs don't seem to run properly if you select them. I tried chatting with Dell Support, and we tried to initiate the system restore at c:\windows\system32\restore\rstrui.exe, but that had a similar "ordinal 423 not found in urlmon.dll" error.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

EDITED.

Step 1: Get into Safe Mode, use Ctrl+Alt+Del to get into Task Manager, run appwiz.cpl, remove IE8 from the installed programs, and restart.

Step 2: Install IE8 again, from a stand-alone installer.

share|improve this answer
    
No can do. Explorer.exe doesn't work. Can't really do anything from the desktop. –  Zoot Oct 2 '10 at 18:54
    
Sadly, I already started formatting and reinstalling before seeing the edited option, so I don't know if it would have worked. If I run into the problem again, this will be the first thing I try. –  Zoot Oct 2 '10 at 19:02
2  
For future reference, not having explorer.exe is not the worst thing in the world. Ctrl+Alt+Del usually brings up Task Manager, and from there you can run cmd.exe, appwiz.cpl, and so on. –  user3463 Oct 2 '10 at 19:05
    
Since I was also having issues getting into safe mode, as pressing F8 didn't work, users with issues getting into safe mode should see this thread- superuser.com/questions/76476/how-to-start-xp-in-safe-mode –  Zoot Oct 4 '10 at 11:13
    
Just had this issue today on a laptop. Removing IE8 and rebooting and explorer.exe opens perfect. –  music2myear Jul 7 '11 at 15:51

Reinstall the OS using the provided disc.

I hope this isn't the best answer.

share|improve this answer
    
The problem is urlmon.dll, right? So can you find another machine with the same configuration and copy it over? Reinstalling an OS is a dramatic solution to the problem. –  user3463 Oct 2 '10 at 19:01
    
Yes, urlmon.dll was the main problem, and reinstalling was rather dramatic. I didn't have a similar machine available. –  Zoot Oct 2 '10 at 21:48
    
The second time around, the updates didn't cause any errors or have any issues. Go figure. –  Zoot Oct 4 '10 at 16:50

I used the APPWIZ.CPL without safe mode. It worked: I now have my desktop back.

share|improve this answer
1  
Care to explain a little how this works? –  slhck Apr 8 '12 at 15:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.