Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have my Mac OS X terminal set to display only the active process name. But for some reason when I am at the shell prompt the title displays "Python". But when I type anything at the prompt, it displays "bash" like it should. Any ideas on why this is happening and how I could fix it?

Ok, here is exactly what happens.

  1. I open Terminal, either from a dead quit, a new window/tab, or even after another command finishes.
  2. The Terminal title for the tab and window displays either Python or python.
  3. The Terminal title goes back to bash like it should once I type even a single character at the prompt.
share|improve this question
    
When does it happen? When you open Terminal, for new windows, new tabs? What do your bash_profile etc. look like? My windows first displays "login", then "bash" after opening; do yours? Does it happen when you display more information in the window title? Do new windows open with the default login shell or another command? –  Daniel Beck Oct 3 '10 at 15:01
    
It displays when I open a new tab or window or open Terminal after quitting. When I open a new tab or window it flashes through two other titles before displaying Python. But when opening from a dead quit it shows login, then bash, then Python. And this is my .bash_profile: pastie.org/1196666 –  Wuffers Oct 3 '10 at 15:11
    
Oh, and here is my .bashrc if that would help as well: pastie.org/1196668 –  Wuffers Oct 3 '10 at 15:12
    
What is in your /etc/profile or /etc/bash.bashrc or similar that's related to PS1 or PROMPT_COMMAND? –  Dennis Williamson Oct 3 '10 at 16:38
    
Here is what I have setting my PROMPT_COMMAND and PS1: pastie.org/1196784 –  Wuffers Oct 3 '10 at 16:49

1 Answer 1

up vote 2 down vote accepted
+100

I think it's autojump. Try removing the lines related to autojump from your bashrc and look what happens.

(I think possible offenders are line 87 (complete) and line 105 (PROMPT_COMMAND), but I'm not sure)

share|improve this answer
    
I removed autojump and it works! Thank you so much! –  Wuffers Oct 13 '10 at 21:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.