Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to retrieve some photos taken with the camera on this mobile phone. But upon connection, it doesnt automount. An icon is displayed in computer:/// in Nautilus (Ubuntu/Gnome). But upon doubleclicking, I get an error about it failed to mount.

The phone is listed (by name) in lsusb when connected.

Comparing ls of /dev when the phone is connected and when its not displays some extra devices detected on the phone:

$ diff deva devb
4a5
> cdc-wdm0
82a84
> serial
84a87
> sg2
156a160,161
> ttyACM0
> ttyACM1
173a179,188
> usbdev6.10_ep00
> usbdev6.10_ep02
> usbdev6.10_ep04
> usbdev6.10_ep07
> usbdev6.10_ep81
> usbdev6.10_ep82
> usbdev6.10_ep83
> usbdev6.10_ep84
> usbdev6.10_ep86
> usbdev6.10_ep87

When connecting, the dmesg displays a few errors about the phone:

[15725.533224]  sdc: sdc1
[15756.100269] usb 6-2: reset full speed USB device using uhci_hcd and address 7
[15756.263469] cdc_acm 6-2:1.3: ttyACM0: USB ACM device
[15756.267698] cdc_acm 6-2:1.1: ttyACM1: USB ACM device
[15756.289445] sd 10:0:0:0: [sdc] Device not ready: Sense Key : Not Ready [current] 
[15756.289452] sd 10:0:0:0: [sdc] Device not ready: Add. Sense: Medium not present
[15756.289459] end_request: I/O error, dev sdc, sector 1920896
[15756.289463] __ratelimit: 30 callbacks suppressed
[15756.289467] Buffer I/O error on device sdc, logical block 240112
[15756.304443] sd 10:0:0:0: [sdc] Device not ready: Sense Key : Not Ready [current] 
[15756.304450] sd 10:0:0:0: [sdc] Device not ready: Add. Sense: Medium not present
[15756.304457] end_request: I/O error, dev sdc, sector 1920896
[15756.304463] Buffer I/O error on device sdc, logical block 240112
[15756.304543] Buffer I/O error on device sdc, logical block 240126
[15756.304560] Buffer I/O error on device sdc, logical block 240126
[15756.304584] Buffer I/O error on device sdc, logical block 0
[15756.304589] Buffer I/O error on device sdc, logical block 1
[15756.304600] Buffer I/O error on device sdc, logical block 0
[15756.304615] Buffer I/O error on device sdc, logical block 0
[15756.304633] Buffer I/O error on device sdc, logical block 240127
[15756.304649] Buffer I/O error on device sdc, logical block 240127

A /dev/sdc shows up when the phone is connected (strange it isnt displayed in the diff), but no /dev/sdc1.

The phone works as expected under Windows. Ive tried some phone related software under Linux (like Wammu) but none has succeeded in accessing it. I just want to retrieve the photos (files) no contact/sms syncing or any other advanced operation.

Google found some success stories but nothing that helped me make progress. Tried to get help from #ubuntu but nothing there either.

  • Could the memory on the phone be corrupt?
  • Can the phones memory be accessed like a regular flash drive?
  • ... or do I need special Linux drivers?
  • Help! :)
share|improve this question

1 Answer 1

up vote 2 down vote accepted

It seems like Linux is trying to use your phone as a modem, which is clearly not what you are trying to achieve. Don't know about the k750i, but on the SonyEricssons I had, you could configure what kind of connection the phone should perform when plugged into a computer via USB.

share|improve this answer
    
Would that be a setting on the phone or on the computer? There is no dialog displayed on the phone upon connection, but it does make a sound. –  mizipzor Aug 7 '09 at 14:09
    
That's a setting on the phone. Go to the configuration menu, choose the connections tab and find the USB entry in the menu. –  innaM Aug 7 '09 at 14:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.