Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sometime today, something occurred with my machine where the caps lock key is now mapped to Shift. It's annoying as I need to use Caps Lock for, among other things, a spreadsheet that I'm working on (not to mention CRUISE CONTROL, etc).

The only remotely plausible cause for this is the following registry entry, located at the following location:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout

The key is as follows:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,2a,00,3a,00,00,00,00,00

I don't have anything like AutoHotKey or such installed, and I didn't get a new keyboard, or change my keymapping. I lock my PC while it's unattended, and I run the domain here, so it's not someone else messing with my stuff.

share|improve this question
    
Does it persist over a reboot? –  mas Aug 7 '09 at 14:41
    
Is it definitely caps lock, or just the first key press after pressing shift results in a capital letter? –  Marko Carter Aug 7 '09 at 15:42
    
It persists after a reboot. And Marko, when I say caps lock is mapped to the shift key, it shows up as the left shift key on On Screen Keyboard, and pressing Caps Lock 5 times will make the Sticky Keys dialog come up. –  phuzion Aug 7 '09 at 17:56
add comment

1 Answer

up vote 4 down vote accepted

In my XP there is no "Scancode Map", just deleting that value should reset keyboard layout to default.

Some people here at my office prefer to swap r-ctrl with caps lock. Got the following .reg scripts to change this:

caps-ctrl-swap.reg:

REGEDIT4
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,03,00,00,00,1d,00,3a,00,3a,00,1d,00,00,00,00,00

Is for swaping

caps-as-ctrl.reg:

REGEDIT4
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,02,00,00,00,1d,00,3a,00,00,00,00,00

Is for mapping capslock to ctrl only

(reboot might be needed after changing those, but unsure)

share|improve this answer
    
I deleted that registry entry, and it's still happening. –  phuzion Aug 7 '09 at 15:15
    
Did you reboot after? If so, is the registry value still gone? –  Joakim Elofsson Aug 7 '09 at 15:34
    
What do you know, it works. –  phuzion Aug 7 '09 at 18:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.