Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tend to have a few Word documents that I keep open all the time, with notes for a long-running project. Normally they are all minimized.

The problem is that when I click on a different .doc or .docx file in Windows Explorer, even though the new document opens in its own window, the other, minimized Word documents get restored, too. Now I have several restored windows that I wanted to keep minimized.

I started noticing this problem on Windows 7, but I'm not sure if it's unique to Windows 7. I'm using Word 2007.

share|improve this question
    
I have almost the same behaviour in Win7 RC1 though only one of the minimised docs is restored. Similarly with Excel 2007, opening a spreadsheet in Explorer briefly displays a minimised spreadsheet which is then hidden by the newly opened one until that is closed, when it is left restored. Anyone know if this still happens with Win 7 RTM? –  pelms Aug 23 '09 at 0:25
    
Just boot into OS X - works fine there :P –  John Stauffer Sep 4 '09 at 14:17

3 Answers 3

up vote 3 down vote accepted

You can fix this problem by blocking Word from using DDE to open files.

In the HKEY_CLASSES_ROOT\Word.Document.12\shell\Open key:

  • Delete or rename the ddeexec sub-key

In the HKEY_CLASSES_ROOT\Word.Document.12\shell\Open\command key:

  • Delete or rename the command value (not to be confused with the command key.)
  • Edit the (Default) value and add "%1" (including quotes) at the end

This solves the problem for .docx files. If you also want to solve it for .doc files, do the same thing for Word.Document.8

Thanks to: Rafael's Within Windows which has detailed instructions.

share|improve this answer

In Vista at least, if you have multiple Word windows minimized and double click to open a document in Windows Explorer, it will (apparently) randomly pick ONE of the minimized windows to pop open.

This behavior is a little bit different than Joel describes above for Win7

share|improve this answer

This is not actually an answer, but rather a workaround.

There's an option under "Word Options / Advanced / Display", named "Show all windows in the taskbar". Turning it off hides all Word icons in the taskbar but one. This way, the described behavior disappears, but at the same time, also the ease of restoring a minimized document.

The only way to browse between the open documents is now with the "Switch windows" button under the "View" menu.

enter image description here

Edit: I did the test on MS Vista, as I don't have a Windows 7 machine at work.

Edit #2: I can confirm that the behavior after turning off "Show all windows in the taskbar" is the same also on Windows 7.

share|improve this answer

protected by Diago Nov 10 '10 at 19:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.