Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In the last few months I've had to make some changes to file sharing on our home LAN. We now have a Windows 7 laptop and a Mac Mini and I had to move away from simple file sharing.

I find myself now, when I create a shared folder that I have to add the "Everyone" user and give it full control to allow other computers to access my files and vice versa. We have other XP machines too.

My problem is that if someone creates a file in a shared folder I then have to add "Everyone" for each file, even if the shared folder is on my PC and my wife creates the file on my PC from her laptop. I can't access it on my PC even though the file is on my computer.

Please help me!

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Did you try the "advanced" window in the security tab of the folder and tried checking the two checkboxes, adding "everyone" to the folder in the process?

share|improve this answer
    
Erm, not sure, I've just had a look in there and I cant see that option –  Jules Oct 5 '10 at 8:55
    
I mean I didn't d that when i setup up the folder and I can't see that option now. –  Jules Oct 5 '10 at 8:58
    
sadpanda.us/images/234754-9HWA7FC.png , it's the two down there. Sorry for German interface –  sinni800 Oct 5 '10 at 8:59
    
Do you have "Simple File Sharing" (Tools > Folder Options... > View then scroll down to the bottom of the advanced settings list box) enabled? –  ChrisF Oct 5 '10 at 9:00
    
@ChrisF Oh, I forgot he could have that activated still... –  sinni800 Oct 5 '10 at 9:01

The default permission when sharing a folder from Windows Vista or Windows 7, depends on whether you have enabled password-protected file sharing. If password-protected file sharing is not enabled, everyone is granted "Full Control" permission to the files in the shared folder. If password-protected file sharing is enabled, you must add the users or groups you want to grant access to.

In Network and Sharing Center window, Change advanced sharing settings, you should turn off password protected sharing (details here). My only problem, not having Win7, is the fact that when password protected sharing is off, you only enable simple file sharing. But try it and see.

share|improve this answer
    
It happens with XP too –  Jules Oct 5 '10 at 10:30
    
Do you have a password on Guest? And why can't you go back to Simple File Sharing (which is the simplest solution) ? –  harrymc Oct 5 '10 at 10:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.