Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A long time back, my machine stopped with a blue screen saying disk segment fault.

Now when I start it, it doesn't display anything on the screen - it doesn't even load the BIOS setup if I try.

Nothing happens, although the CPU fan does seem to start. The LED indicator for hard drive access does blink at a specific interval, but there's no video on the monitor.

How should I proceed to recover my data/computer?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

If it doesn't even get past the BIOS screen your system is in all likelihood broken. There is no way recover from that.

You probably have to replace the motherboard and/or the cpu. And this in turn means that if your computer is more than a couple of years old you probably have to buy new RAM sticks to.

There is a small chance that there is a problem with you memory-sticks or it's sockets in the motherboard. I'm mention this because it's the one thing that's pretty easy to test yourself.

To test this:

  1. Borrow a memory stick that you know works and fit's your computer
  2. Remove all the memory from the broken system
  3. Test the borrowed stick in each the memory slots one at a time to see if it boots
share|improve this answer
    
@Nifle there should be some tweaks to tracedown , which part is faulty –  Jigar Joshi Oct 5 '10 at 11:21
    
@abc - The only way to do that is to remove everything besides the motherboard and the cpu and test it in a different computer. How can you tweak anything that will not start at all? –  Nifle Oct 5 '10 at 11:25
    
@Nifle ok. still waiting for some more twaeks , else i would try this. as its not suitable here to do :) –  Jigar Joshi Oct 5 '10 at 11:26
    
@abc - I assumed you have given the computer a good cleaning and made sure all the cables are firmly in place and graphics cards and ramsticks are all the way down in their slots. If not do that, you might get lucky. –  Nifle Oct 5 '10 at 11:30
    
I checked every thing cleaning up & repluggin , didn't work –  Jigar Joshi Oct 5 '10 at 11:32
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.