Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a DVD in my macbook pro with 10.5 but I can't find the eject button in the finder. Holding the physical eject button on the keyboard doesn't do anything. Is there a CLI way to eject the DVD or an alternate GUI method?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

Try

drutil eject
share|improve this answer
    
It's not working, any other suggestions? –  Thierry Lam Oct 5 '10 at 16:35
    
If nothing of the above works, consider the idea that your drive might be malfunctioning. Are you actually 100% sure there is a disk in the drive? –  BloodPhilia Oct 5 '10 at 16:37
    
It looks like this command made DVD volume and the the eject button appear again in the finder. –  Thierry Lam Oct 5 '10 at 16:45
    
@thierry Great it worked! –  BloodPhilia Oct 5 '10 at 16:56
add comment

Under "alternate method", press and hold the mouse button while the system is booting up (turn computer off, press mouse, turn computer on, wait for cd). The only time this hasn't worked for me is when one of the internal connectors was not seated correctly.

share|improve this answer
add comment

If you are using VMWare Fusion or any other "dual computer" software, the "other" computer may have ownership of the drive. In my case, switching to the Windows machine and ejecting the DVD from there was the answer.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.