Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Background: I'm wanting to move away from Apache and came across this article which walks through an install of nginx, PHP-FPM and APC. On trying to follow these instructions on my user account of my host I ran into a problem: lack of apt-get and broken yum. So, I tried to build apt-get from source:

wget http://apt-rpm.org/releases/apt-0.5.15lorg3.tar.bz2
tar -vxf apt-0.5.15lorg3.tar.bz2
cd apt-0.5.15lorg3
./configure --prefix=$HOME

This is where I run into an issue:

...
checking db1/db.h usability... no
checking db1/db.h presence... no
checking for db1/db.h... no
checking rpm/rpmlib.h usability... no
checking rpm/rpmlib.h presence... no
checking for rpm/rpmlib.h... no
configure: error: Can't find rpmlib.h

Any ideas on how to solve this or get around the issue?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

What do you mean by "broken yum"? Is it not finding the package, or is it throwing you Python errors?

You can always try cleaning the yum cache, it fixes a lot of issues:

#yum clean all

If the main package manager on your OS is broken, the last thing you want to do is install another package manager, especially from source. Dependency hell is the last thing you need. I'd recommend trying to fix yum first and foremost.

share|improve this answer
    
When I try to use yum I'm getting the error: "Config Error: Error accessing file for config file://///etc/yum.repos.d/WebFaction.repo". I'll take your recommendation on board though, thanks! –  Nev Stokes Oct 5 '10 at 22:14
    
Ah, you're with webfaction hosting. What are the permissions for that file when you do a ls -la /etc/yum.repos.d ? pastebin.com –  John T Oct 5 '10 at 22:29
    
@Nev, what was your final solution? –  John T Oct 6 '10 at 21:39
    
Thanks for the help John. Basically any package manager is a no-go so I've been working with the support guys at Webfaction to build nginx etc. from source. Which is, er, "fun"! –  Nev Stokes Oct 7 '10 at 8:50
  1. Download and install the rpm forge release, which will enable YUM to access: *

        wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.3.6-1.el5.rf.i386.rpm
        rpm -i rpmforge-release-0.3.6-1.el5.rf.i386.rpm 
    
  2. After this is installed (it takes a long time), you can install APT.

  3. You should now be able to use apt-get and install the apt repositories. You will have to add your sources at /etc/apt/sources.list.d

This link might be helpful.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.