Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been trying to copy a large folder containing hundreds of music files to my external hard drive, which is actually a regular SATA hard-drive inside an enclosure, attached to my laptop via USB.

I've attempted this several times, but whenever I do, somewhere along the line I'll get a blue screen of death and the system will dump memory contents to the hard drive before doing a complete restart.

The enclosure is brand-new, so I assume it wouldn't be the problem.

So that leaves the hard drive, but the hard drive itself is relatively new as well (well, 1 year old, but hasn't been used much.)

So does this mean the hard drive is completely cactus?

share|improve this question
    
Can you try a different hard drive (that you know works) in the enclosure, to first of all rule out the enclosure as a problem? –  Ash Oct 6 '10 at 1:43
    
Have you tried copying only a portion of the files at a time? Does it always BSOD on the same file? –  MBraedley Oct 6 '10 at 2:38
    
What OS are you running? This is usually indicative of a USB driver issue. I've seen it on 64-bit Windows. –  user3463 Oct 6 '10 at 3:30
    
@Randolph, Yeah I'm running 64-bit Windows 7. –  jonathanconway Oct 6 '10 at 4:32
add comment

1 Answer 1

up vote 3 down vote accepted

As you're running a 64-bit version of Windows, I can say from experience that your issue is the USB controller's drivers.

Have a look at finding the right drivers on the motherboard manufacturer's website.

The good news is, your drives are probably both fine.

share|improve this answer
    
Thanks for the tip! I'll give it a try. –  jonathanconway Oct 6 '10 at 4:38
1  
Best of luck. I had a server that worked fine until I reinstalled. I forgot which drivers I used, and the USB drive has blue-screened every time since. I eventually moved it to a 32-bit machine and backed up over gigabit ethernet. –  user3463 Oct 6 '10 at 4:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.