Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've configured a squid proxy which requires authentication on my home gateway. On a lan PC running windows 7 when I try to access it from Firefox I get a blank page; both chrome and internet explorer also return fairly meaningless errors). In all cases the squid log shows it is serving 407 Proxy Authentication Required. This is to be expected.

Now I'm left scratching my head trying to figure out where exactly do I provide my proxy authentication credentials. I cannot see this either in the

  • Windows 7: Internet Properties -> LAN Settings -> Proxy Server
  • Firefox: Tools -> Options -> Advanced -> Proxy -> Settings

So where do I put this information in? From googling I get the impression I'm supposed to get a prompt at some stage, but I haven't seen one so far

share|improve this question

1 Answer 1

One thing to try is:

Go to Administrative Tools -> Local Security Policy -> Local Policies -> Security Option, and change "Network security: LAN Manager authentication level" to "LM & NTLM - Use NTLMv2 session if negotiated".

More info that I can't verify (not a Squid user) can be found in :
Getting Squid to authenticate with kerberos and Windows 2008/2003/7/XP

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.