Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a cable router connected to my cable ISP. On the LANs are 4 computers, one of which is a dual boot XP/Win7 machine. I was given an ADSL wireless router which I connected to one of the LAN sockets on my cable router. I don't have an ADSL connection. All the machines connect correctly, some wirelessly, when my dual boot machine is in XP or off. However, when I go into Win 7 on that machine it finds the ADSL router and wants to connect through that (there's no ADSL connection) instead of my cable router and modem. I've turned DHCP off on the ADSL modem and even tried bridging its connections but neither of these have any effect. To get 7 connected, I have to either disconnect the ADSL router, or switch it off. Remember, the SAME computer on the same LAN works perfectly with the same router connected in XP!

How then, can I get Win 7 to recognise the correct router?

share|improve this question

2 Answers 2

What you have here is one of two things:

  • IP Address Conflict (between your two routers)
  • UPnP Advertising your router

I'm guessing it is the UPnP problem, since none of your other machines have this issue. Just go into your ADSL router and disable UPnP and you should be fine.

share|improve this answer
    
Thanks for your input, Brad, but I just checked the settings on the ADSL router and UPnP is already disabled. I think you may be right about the address conflict, as both have the base IP address of 192.168.1.1, but they happily work together when XP is being used. –  Henry Oct 8 '10 at 21:02
2  
Look, you cannot expect to use the same IP address for two devices on the network. That does not work. I can't emphasize this enough. You absolutely MUST NOT use the same IP on two devices and expect decent results. That's your problem right there. Fix it. –  Brad Oct 10 '10 at 17:13

First problem, as Brad said, you cannot have two devices with the same UP on the same network segment.

Make sure the ADSL DHCP server is off too, but you've said you've done that.

You might turn off Win7's 'helpful' identification of router devices. It does a scan for SNMP enabled devices and tries to configure itself thusly, regardless of DHCP reports from elsewhere. (Thanks Microsoft! E.E.E that standard too!)

No, I can't remember the proper name for this option, but it'll be in the Network section of the Control Panel, I don't use Windows machines often enough to know what it's called. (I know where to look though!)

Change that IP address... if you've disabled its DHCP server and bridged the connections on the ADSL wireless router, then you can set the IP address to anything you desire (well, Class C private ranges of course!). I'd recommend 192.168.2.1 or something, then write it down on a sticky and tape it to the bottom of the ADSL so you can find it to admin it later when you forget the IP addr.

Windows 7 does more hand-holding than XP did, so it does more things to be "helpful". "Helpful" is a relative term...

share|improve this answer
    
Thanks, lornix, for your reply but I had already sorted it by changing one of the routers' IP address, as you suggested. They were both 192.168.1.1 and I wonder how XP found them both! Once again, thanks for your input. Henry –  Henry Nov 7 '10 at 18:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.