Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Upgraded Vista to 7 last day and my wireless laptop adapter is behaving funny.

First it was killing me with resource conflict issues, but I just did a fresh Win 7 installation and the thing just does not seem to register now - as if it were not plugged in at all!

Is there some utility that will allow me to see all devices physically connected to my laptop, regardless of whether they have a driver or not?

I am willing to experiment with external OSes ( via bootable USB etc ) and self contained tools - whatever will help get the job done.

share|improve this question

If you're talking about embedded devices on your laptop, then it's very likely you'll need the driver. Don't forget about the chipset driver -- I once had a fresh install that device manager didn't "see" the additional devices like SD reader, webcam until I install the right chipset driver.

share|improve this answer
    
My problem is EXACTLY what you described - device manager does not seem to "see" a device, even with a exclamation beside it or something. It's as if the device did not exist at all. But I know the device is connected, and last time before it stopped showing up, I had a resource conflict for the driver. – PoorLuzer Oct 7 '10 at 1:47
    
Best bet is to go to the laptop manufacturer website and download the drivers. – fseto Oct 7 '10 at 2:05

I've used SIW (System Information for Windows) in the past.

share|improve this answer

The best way to enumerate connected devices is to use any bootable linux livecd and grab the result from lspci

share|improve this answer
    
Will this work if I installed openSUSE? I am thinking of doing that anyways. – PoorLuzer Oct 9 '10 at 5:19
1  
@PoorLuzer yes. lspci and hwinfo should be present on all linux distributions. additional realtime data can be found in /proc/ under linux. – Greg Buehler Oct 9 '10 at 6:37
    
Thanks! That was helpful. – PoorLuzer Oct 9 '10 at 14:34

If you've got devices physically attached but not working, you should have some indication in the Device Manager.

On XP it's at System Properties > Hardware > Device Manager and they show up with "?" icons - I haven't got 7 installed to double check if it's still the same.

share|improve this answer

On Windows 7:

Right Click Computer
Select Properties
Select Device Manager from top left
Expand Universal Serial Bus controllers section
share|improve this answer
up vote 0 down vote accepted

I am not sure if this is a case unique to my situation, but I finally solved the issue.

The thing is like this : All these problems started happening after I installed a 2GB RAM module into my laptop. The laptop specification says that it can handle max 3GB RAM. I have 2 slots of RAM and the 2GB RAM was installed in the second slot and one of the existing 512MB RAM in first slot ( I had to swap out the other pre-installed 512MB ).

I tested my WiFi card on another laptop to verify if it was dead - it was indeed working.

Hence, I brought back my laptop hardware configuration back to what it had been ( using existing 512MB RAM cards ) and the WiFi card started to "work again" - Windows 7 installed drivers for "PCI-PCI Bridge" and then the AR5007 driver.

Before deciding to return the 2GB RAM, I just gave a last try and swapped out the 512MB in the first slot and inserted the 2G.

It's working even after multiple reboots.

I am not sure if I will face problems in the future ( previously, the issue was intermittent before the wifi went "dead" the last week ) - but I am hoping for the best.

Thankfully, I have some more information to work with, the next time, forbid, my wifi goes dead.

However - I am still stumped that there was no software that detected the wifi card ( might be because it was some kind of issue/address conflict deep in the motherboard itself at the hardware level? )

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .