Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've setup VirtualBox to run a Windows 7 Guest under a Windows 7 host. I get sound, but it's "skippy" and/or clackling when I listen to music on Winamp or Media Player Classic. Haven't tried other players yet.

The setup was done as follows:

  1. Installed a VirtualBox on my machine.
  2. Created a new Windows 7 VM. Set it up to have 1936 MB (RAM) and 64 MB (VIDEO), and a HD of 20GB.
  3. Installed Windows 7 N from a clean install under the VM.
  4. After Windows installed, I've run Windows Update. Got all fixes available and made sure it installed Realtek AC97 drivers.
  5. Installed VirtualBox extensions on the Guest.
  6. Installed Winamp on the VM, and copied a few mp3 files to the guest in order to test it.

That's when I've found out that the sound wasn't working properly. Not sure if this is a common or a very specific problem, does anyone experienced anything similar on a Windows Guest or even on a Linux Guest?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Yeah... that happens. You're running a machine on a machine, and there is a ton of overhead, not to mention issues with CPU priority for your virtual machine and what not. Also, that is a lot of RAM on a VM... how much do you have on your PC?

This is a very common issue. At least in Winamp, you can increase the buffer for sound card playback. I'd imagine you can do the same in Windows Media Player. This may help you, but keep in mind that the sound card is software controlled as well.

share|improve this answer
    
I have 4GB of RAM. So far I haven't had performance issues with the host, and since I'm running Win7 on the guest, I thought I'd need the extra RAM. Not sure what would be the optimal configuration, though. I suspect that it was a performance problem due to emulated hardware, but is there anyway I could improve sound? –  Bruno Brant Oct 7 '10 at 23:39
    
Did you try my buffer suggestion? –  Brad Oct 8 '10 at 16:18
    
I did... actually, it was one of the first things I've tried. It improves a bit, making the skips less frequent. –  Bruno Brant Dec 2 '10 at 15:55
add comment

I was running Win 7 guest in Ubuntu 10.04 host, but the fix may be the same:

Unselecting the "Enable Nested Paging":

settings > system > acceleration > enable nested paging
share|improve this answer
    
Thanks for the suggestion. I tried it, but didn't improved the sound. –  Bruno Brant Dec 2 '10 at 15:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.