Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have quite a strange issue with (supposedly) my keyboard mappings.

  • while using GNOME session:

    • lowercase 'v' is not working as it should - no keypress is reaching apps;
    • while I'm holding V key depressed, gnome-terminal console shows a hollow cursor (just like when input focus is in some other window) and nothing is printed;
    • uppercase 'V' is working just fine (that is Shift+V);
    • if I press AltGr + V, a lowercase 'v' is printed;
    • if I'm typing quickly, sometimes pressing V key to get a lowercase 'v' is not just being ignored, but also the next symbol typed is swallowed and not printed out;
    • this issue is present for the USA keyboard layout, as well as for the Russian keyboard layout.

  • while using TTY console (Alt+Ctrl+F1, etc):

    • everything works as it should (i.e. lowercase ' is printed whenever I press it);
    • no problems with the physical keyboard.

I haven't done any editing of any gnome/X configs and/or keyboard mappings.

What should I check?

PS. I'm a newbie to Linux (just 1.5 years) - please be explicit in your recommendations. :)
PPS. This is my Ubuntu 10.04 Linux version:

$ uname -a
Linux hostname 2.6.32-25-generic #44-Ubuntu SMP Fri Sep 17 20:05:27 UTC 2010 x86_64 GNU/Linux

Update - stty output:

$ stty -a
speed 38400 baud; rows 43; columns 151; line = 0;
intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = M-^?; eol2 = M-^?; swtch = M-^?; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W;
lnext = ^V; flush = ^O; min = 1; time = 0;
-parenb -parodd cs8 hupcl -cstopb cread -clocal -crtscts
-ignbrk brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc ixany imaxbel iutf8
opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0
isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke
share|improve this question

Sounds like the lnext parameter in the terminal driver got mangled somehow. You can use stty to change it.

share|improve this answer
    
I've added stty output to the question above. Looks fine for me. Are there any visible issues? – Serge Broslavsky Oct 7 '10 at 17:45
up vote 0 down vote accepted

Thanks to Chris Billington on askubuntu.com I've found the cause of the problem - it was a Compiz key mapping for V key (initiate viewport switching).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .