Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have been trying to enable Virtualization of my cpu to run a 64 bit guest OS. Anybody having an idea ?

EDIT : My cpu supports virtualization. http://ark.intel.com/Product.aspx?id=35562 the problem is I couldn't enable it. Setup screen doesn't have any option to make it! I'm currently using Windows 7 Ultimate x64

share|improve this question
Enabling VT-x ..might cause an slight headache marcansoft.com/blog/2009/06/… –  Sathya Oct 7 '10 at 13:30

4 Answers 4

Short answer: You can't. Or at least you shouldn't.

Long answer:
Usually you enable things like VT in the BIOS. To get into the BIOS, reboot the machine and it will tell you which key (mostly F1/F2/ESC/DEL or similar) you have to press in order to get there. Unfortunately your machine's BIOS won't help because there is no option to activate VT. (Yes, Acer intentionally crippled your machine. So do many other manufacturers.)

Now the "You shouldn't"-part: You could try to install a modified version of the BIOS but that might introduce new problems like instabilities or even brick your notebook. More info:

share|improve this answer

Going to need a bit more than that: virtuliastion software and processor spec?

If you only have a 32-bit processor AFAIK you won't be able to run 64-bit OS.

share|improve this answer
QEMU will run a 64-bit OS just fine on a 32-bit processor. –  Ignacio Vazquez-Abrams Oct 7 '10 at 9:44
Ok, more of a virtualbox/virtualpc guy myself. –  tombull89 Oct 7 '10 at 10:07
As will VirtualBox. @tombull –  Sathya Oct 7 '10 at 13:21

Check that your CPU supports hardware virtualization, not all of them do. If it does the setting to enable it is in BIOS.

EDIT: Your CPU does support hardware VT, just go into BIOS and make sure it is enabled.

share|improve this answer
My cpu supports virtualization. ark.intel.com/Product.aspx?id=35562 the problem is I couldn't enable it. Setup screen doesn't have any option to make it! –  Kubi Oct 7 '10 at 10:05
Look in the BIOS, not the "setup screen". –  Fake Name Oct 7 '10 at 10:57
how ? it would look silly but I really don't know how to access there :( –  Kubi Oct 7 '10 at 10:59
Ooo seems 8930 uses UEFI. refer marcansoft.com/blog/2009/06/… @Kubi –  Sathya Oct 7 '10 at 13:25

Okay, so I know, that this - considering the age of this question - is necromancy, but I ran into the exact same problem and managed to solve it. Easily and safely. So for the sake of all the Google users out there, here goes.

Obligatory relevant xkcd.

As already metioned in the linked blog post by marcan, there's a BIOS update to version 1.21 floating around, that has virtualization enabled by default. There still is no BIOS setting though.

The 1.21-clean.fd file provided by marcan did not work for me though. This might be due to the fact, that I chose a different and "more official" way for flashing the BIOS. I found an (or the) update in a thread on bios-mods.com instead.

There you can download an archive that uses the same flashing method as the official Acer BIOS update found in their drivers download center. I like to believe, that this reduces the risk of bricking my laptop. For downloading this file, you need an account. I didn't have on either and just created a throwaway. They do send a confirmation mail though, so enter a valid address.

DISCLAIMER: This is what worked for me on a Acer Aspire 8930G. But what worked for me, might not work for you. Although I see no reason why, you could very easily brick your laptop. I and superuser.com are not responsible for your actions. Acer might not cover this with their guarantee, but judging from the age of this model, you won't have any guarantee left anyways.

Now here's what I did:

  1. Get the official Acer BIOS update, version 1.20

    1. I used Windows 8 for this. But Windows 7 and Vista should be fine aswell. I am positive, that the method linked in the blog post will work for Ubuntu, but I wasn't positive enough to risk bricking my 2.000 € lapop.
    2. Download this .zip or get the link yourself from the drivers download center.
    3. Extract it to your desktop or wherever you have easy access.
  2. Install the 1.20 update

    1. Make sure, that your laptop is plugged into an external power source and has enough battery power to run for at least 10 minutes.
    2. Close all unnecessary applications.
    3. Run BIOS_Acer_1.20_Windows_AS8930/Windows/InsydeFlash.exe as Administrator.
    4. Disregard the choice of font (Comic Sans) and check the version numbers. It should read something like 1.5 or whatever to 1.20.
    5. In the dialog that popped up asking you if you want to flash, choose Yes or whatever you need to click to continue. That is the point of no return.
      • Do not turn off your god-damn Laptop.
      • Do not press any keys or buttons
      • Do not move your mouse.
      • Do not trip on the power cord.
      • Do not even breath.
      • Don't even even.
    7. The screen will freeze and may turn black. You may hear strange sounds. This is normal and no reason to panic. The whole procedure will take about two minutes. After it finished, the laptop will automatically shut down.
  3. (Optional) Reconfigure your BIOS

    1. Pesss F2 wile rebooting.
    2. You get to the BIOS setup, where you can reconfigure it, as all previous setting will be lost.
    3. You might need to change your boot order, as I did, or enable the boot menu, as I did.
  4. Get the 1.21 update

    1. I got it from from a thread on bios-mods.com. There might be other sources, but this is the one I used and it worked.
      • This update also contains SLIC 2.1 for Windows 7 and up.
      • The md5sum is db73189fcff72de2fb576b5a0c228f46. Since this is a third-party source, you should verify that.
    2. Extract it to your desktop or wherever you have easy access.
    3. This time, there's no DOS folder inside.
  5. Install the 1.21 update

    1. Make sure, that your laptop is plugged into an external power source and has enough battery power to run for at least 10 minutes. 2 Close all unnecessary applications.
    2. Run BIOS_Acer_1.21_slic21 VT Windows_AS8930/Windows/InsydeFlash.exe as Administrator.
    3. Check the version numbers. It should read 1.20 to 1.20.
    4. Repeat the steps as in 2.5 to 3. on.

If everything went okay and you were able to boot again, you now have a VT-x enabled laptop! Lucky you! :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.