Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

A few days ago I was copying some stuff on a 32 GB micro-SD card put inside an SD adapter, via my laptop's SD card reader slot and the copy froze.

I already had a backup of the data, so I decide to just unplug the card and reformat it if something went wrong. Something did go wrong, since I was asked to reformat the memory card as soon as I put it back in the slot, but now I can't reformat it.

I've tried to format it via Windows Explorer and sometimes it freezes, sometimes it says "Unable to format". Disk Management freezes too, as does the command line format and a third party, low-level format tool.

What can I do to get this micro-SD card formatted?

share|improve this question

This happened to me as well, I'm not very fond of Explorer's formatting techniques. If you have a Mac or Linux machine around, use that to format it. Disk Utility on mac is great. I'm pretty sure it would also format on an Android if you can plug it in the phone (b/c it's Linux and pretty hardcore) and maybe some of the higher end cameras.

That's the easiest way to do so, if not, I would recommend looking for a windows program that formats the card 'securely' so that everything's wiped off of it.

share|improve this answer
I tried with a Canon EOS450D but it refused to format it, although I don't really know if it can handle sdHC. I'll try both a Mac and Linux in the evening. – Claudio Mezzasalma Oct 7 '10 at 9:34
I've done it on a Panasonic Lumix and and Kodak Easyshare (point&shoot), but the card I had was 4gb. – Muhammad Usman Oct 7 '10 at 9:51
This answer was unnecessary to make a wiki. When you do that you don't get any reputation from it and other people can edit it. Setting it wiki it is supposed to lower the rep threshold for editing so that other people can help and add to your post. I don't think your answer needs improving. – Nifle Oct 7 '10 at 9:54
@Nifle: Didn't know that. I thought it'd be easier for people to just put their thoughts and I thought wikis allow for editing the actual text of my answer because I felt like I might be a bit off about the Linux/Mac part because I primarily use a OS X. And rep will come if it has to. :) – Muhammad Usman Oct 7 '10 at 10:18

Is this Windows 7? There was actually a bug with this that was addressed with an optional Windows Update a while back - make sure it's installed.

EDIT: Actually, now that I look, this is only a problem if it's bigger than 32GB, but there's no telling how their rounding works so it's worth a shot. Also, this answer might help somebody else out down the road...haha!

share|improve this answer
It seems I have this hotfix already installed, at least on my work PC where I am reporting freezes too. – Claudio Mezzasalma Oct 7 '10 at 15:40

Not sure if the HP USB disk storage format tool will work, but it's worth a try as it has 'resurrected' unformattable USB sticks for me. If it doesn't work through the SD slot it might with a micro-SD USB adapter.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.