Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an external monitor and it takes a couple seconds to warm up, so when I am waking my computer up from sleep I usually bump the mouse and move on to something else for a couple seconds.

The problem: Snow Leopard only shows the login screen for 15 or 20 seconds before putting the computer (and monitor) back to sleep.

The question: how can I lengthen the amount of time it waits for me to login?

share|improve this question
up vote 0 down vote accepted

This should be controlled by the Energy Saver preference pane. That seems very quick for the machine to go to sleep. How many minutes is Display Sleep preference set for?

share|improve this answer
Both computer and display are set to 10 minutes. The only other thing I can think of (and I haven't check it out) is the check box for "Put the hard disk(s) to sleep when possible". – RyanJM Oct 7 '10 at 15:08
Maybe there's something strange going on with the energy saver profiles. Open the Terminal and enter "pmset -g" to display the current profile settings. The minimum Sleep setting is 1 minute apparently. See the man page for pmset for more information. Is this a laptop or a desktop machine? – Theo Belk Oct 9 '10 at 19:25
Ok, I thought I might be insane and making things up, so I timed it. From sleep, when I hit a key on the keyboard it takes 10 seconds for the screens to warm up, then 26 seconds later (total of 36) the computer goes back to sleep. I will have to look at pmset later, but how did you find out about that? (Also, sorry it took so long to respond) – RyanJM Oct 21 '10 at 23:52
Oh, and I'm running a MacBook – RyanJM Oct 22 '10 at 3:43
No problem, I haven't been on much lately either. I probably picked up on pmset at an Apple class or maybe on the web somewhere. I think 36 seconds is just too fast for Energy Saver to be the culprit. You might do a System Management Controller reset. The method varies depending on what model you have. Take a look here for more information: – Theo Belk Oct 24 '10 at 16:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .