Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two keyboard layout options set in Windows XP, Croatian and English, with Croatian as the default layout. When I write some text and some croatian symbols (like ć,š,ž) the MS Word 2007 gets messed up, arbitrarily changing the active keyboard layout.

So, in some documents, if a caret is on one line, Word sets the keyboard layout to Croatian, then if the caret is on some other line, it switches to English layout. This is strange behavior and I can't figure out why it behaves like this. The shortcut for layout switch is Alt-shift but these keys are not even pressed when this happens.

Is there any reason for this or is this a bug (whether in WinXp or Word)?

share|improve this question

2 Answers 2

I believe word actually tracks the regions in which you use the different keyboard layouts and will switch between them automatically. For example, if you type an english sentence, it should use the english dictionary for spell checking, and then if you go down a few lines, switch the language to Croatian, and type a sentence, then Word will mark this second region as Croatian, and try to use the Croatian dictionary, Croatian grammer rules, etc. (Note, Shift+Alt changes the active system language, not simply the keyboard layout. Changing the system language includes switching the keyboard layout, however). If you click back into the english region of your document, the system should switch back to english automatically.

I do know for a fact that the Windows remembers which language is active in a given application: If you set the language to Croatian in Word, switch to Excel, change the language to English, and then switch back to Word, Windows will switch the language back to Croatian. If you switch back to Excel, Windows will switch the language back to english.

share|improve this answer
    
The interesting thing is that it only started to happen at some point in time, not since the installation, and it doesn't happen on another computer running Win7. –  Kornelije Petak Oct 7 '10 at 19:16
    
This can also happen because Word can also save the region settings within the document. . . –  surfasb Jul 29 '11 at 18:33

I just came across this problem as my 2 year old son where "hacking" on my keyboard. Instead of the normal Swiss Layout suddenly I had English layout - but only in word, nowhere else!

He must have pressed a switch (key combination) to activate this. He did not change the layout in general, only in word.

Then I found this: http://office.microsoft.com/en-us/word-help/automatically-switch-keyboard-languages-HP005258070.aspx

May it help you too.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.