Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

So here's what happens:

I updated my system the other day, was prompted for a reboot for the update to complete but was in the middle of working so I delayed it until after I was done. I reboot and it's broken :(.

It appears to boot normally, with the following exceptions:

The purple Ubuntu load screen no longer displays (though it did for the first couple of times I tried to get in). I hear the login prompt sound, but no login prompt appears. Nor is it simply "invisible" - pressing enter, typing my password, and pressing enter again do nothing. Normally my Bluetooth mouse is functional at this point, but it is not.

GRUB displays recovery options for my current kernel, and for an older one (2.6.32-24). Trying to boot into .32-24 gives me an error saying "udevadm can't do something while udev is not configured".

So I try solutions listed here: Nothing I tried seemed to work, and after further Googling my hunch is that it's a problem with gdm. Please correct me if I'm wrong, I don't know all that much about how Linux/Ubuntu systems work just yet.

Things I'm able to do: Boot to a live CD

Ctrl-Alt-F2 after that login sound plays brings me to a console login, which I can successfully do (it's how I tried the solutions above). This works only under the current kernel.

A hack I'd be willing to explore is removing the login prompt from the console, but I'd prefer to "simply" fix what's wrong. Like that guy, I need to repair the system rather than reinstall.

System: Dell Inspiron 1525 Core 2 Duo Proprietary Driver for Broadcom 43xx wireless

Dual-boot with Windows 7 (which is how I'm posting this, unfortunately I only have this machine and any experimenting requires constant reboots into Windows/brokenbuntu)

Last package installed was Moonlight, but it appeared to install properly.

Kernel: 2.6.32-25

Edit: After working with Karl's suggestions, it seems that the problem is with gdm.

Error exit status 245 when attempting to sudo apt-get install --reinstall gdm, also an error processing gdm when running sudo apt-get -f install.

How do I reinstall or repair gdm so that I can get back into my machine?

share|improve this question
up vote 0 down vote accepted

From your Ctrl-Alt-F2 prompt, try sudo gdm-restart and see if it works and/or provides some useful error messages.

share|improve this answer
Great, thanks for your help - appear to be getting somewhere. That brought up: ** (gdm-binary:1642) WARNING **: Failed to acquire org.gnome.DisplayManager ** (gdm-binary:1642) WARNING **: Could not acquire name; bailing out Being an experimenter, I tried sudo apt-get install --reinstall gdm, which returned the following error messages: "dpkg: warning: old pre-removal script returned error exit status 245" and "dpkg: error processing gdm (--configure)". I don't have time to google this right now, but I do think it's a problem with gdm. – cliff Oct 9 '10 at 1:14
Your reinstall could be failing if you're missing dependencies for some reason. Try a sudo apt-get -f install. – Karl Bielefeldt Oct 9 '10 at 5:30
In addition to a line of "error exit status 245", this returned an "error processing: gdm". sudo apt-get -f install did not complete. do I go about reinstalling gdm if these processes don't seem to work? – cliff Oct 11 '10 at 4:42
You could get rid of the pre-removal script. It's at /var/lib/dpkg/info/gdm.prerm. I believe you don't really need it if you are planning to immediately reinstall, but just in case, don't delete it, just move it to your Desktop or something. – Karl Bielefeldt Oct 11 '10 at 13:54
Doesn't seem to do anything, I get the same dpkg: error processing gdm (--configure). – cliff Oct 11 '10 at 17:02

I found some info here, which suggests it is related with zlib - I can confirm that in my case it was zlib issue. However, I needed the zlib 1.2.5 compiled from source for other software, so I found these solutions:

  1. Upgrade Ubuntu (in 11.04 it does not occur, but it does not use gdm afaik?), but it is not really usefull advice

  2. Go to terminal (crtl+alt+f1), login, and run sudo apt-get install nodm and then sudo dpkg-reconfigure nodm choosing to use nodm and providing one's login. Honestly, I've first edited the file /etc/default/nodm manually, but ran the dpkg-reconfigure soon afterwards.

Then restart. There are still many major problems with gnome desktop, so it's rather whole Gnome problem, than only gdm login screen.

Summarizing, I guess update to newer version of Ubuntu or changing to kde + kdm for example are best solutions.

share|improve this answer

Once the system boots to the first screen with no login prompt:

  1. Hit Ctrl+Alt+F1 to go to the text mode login
  2. Log in to text mode with your credentials
  3. Change to the directory where the zlib source is located
  4. Run the command sudo make uninstall
  5. Now reboot using sudo reboot

This worked for me when I had the same problem

share|improve this answer

I have the same problem on Centos6.3. I list my solution below which is inspired by misiak and [startx error when setting up X server on archlinux].

first by

$ sudo ldd /usr/bin/Xorg | grep libz

I get => /usr/local/lib/ (0x00172000)

/usr/local/lib/ link to /usr/local/lib/ be my new install)

I think Xorg should depend on /lib/ install).

Then I

$ cd /usr/local/lib

$ sudo mv

$ sudo ln -s /lib/

$ sudo reboot


share|improve this answer

That message “udev is not configured” makes me think something went wrong doing the updates, and your system has been left in a semi-functional state. Here “configured” has a technical meaning: installing a Debian package means first unpacking its files, then “configuring” it to update configuration files, regenerate caches, etc.

On the command line, try doing

sudo dpkg --configure -a

If this still throws errors, try running it a couple more times. This won't make the errors go away, but might make more packages into a usable state. Then do

sudo dpkg --configure udev linux-image-generic xserver-xorg gdm

to insist on configuring the most important packages.

If at that point you still have unconfigured packages, post the error messages. If you're still unable to access SU from Linux, do

sudo dpkg --configure -a >/media/disk9/dpkg--configure.log

(replace /media/disk9 by wherever your Windows disk is mounted) and post the contents of dpkg--configure.log from Windows.

If dpkg --configure -a succeeds and you still have trouble, my hypothesis was wrong.

share|improve this answer
Aye, I'm somewhat familiar with what configure means in this case, but I already ran a "dpkg --configure -a" (and some of the other dpkg-reconfigure stuff in that other question) and didn't receive error messages while doing so. So I assume they completed just fine. – cliff Oct 9 '10 at 1:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .