Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have windows 7 Ultimate, 64bit. I have installed SQL Server 2008 Express and have created a database in it.

I have a jar that helps me create a connection file to connect to this database. I have used this on several other computers (XP/Win2003) and it has worked fine. alt text

However, testing the connection gives me a connection refused.

So I started troubleshooting by first installing the Telnet client and trying to hit SQL Server Express. No joy: alt text

This is my home PC. No Windows Firewall running. Default install of SQL Server (port number is 1433) Can hit SQL Server in SQL Server Mgmt Studio fine.

  1. Why is Telnet failing?
  2. How to troubleshoot further?

Thanks.

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

Have you enabled TCP/IP as a connection option for the instance in SQL Server Configuration Manager?

share|improve this answer
    
Thank you - that solved the 95% of the issue. Im sure default installs of 2005 SQL Server express have this enabled? Its now saying the sa login is not right. I was pretty certain the default password for sa was sa? –  Simon Oct 9 '10 at 1:02
    
@Simon - the default password for sa is whatever you set it to in the installation, if you enabled mixed mode authentication. See thecodeattic.files.wordpress.com/2010/06/… –  ta.speot.is Oct 9 '10 at 1:07
    
Cheers man. Whats the procedure for changing this without doing a re-install of sql express. –  Simon Oct 9 '10 at 2:11
1  
@Simon - connect in SSMS and follow aspadvice.com/blogs/name/archive/2008/04/03/… then change the password for sa by connecting in SSMS again and under the server expand out "Security" and then "Logins". Right click "sa" and select "Properties". –  ta.speot.is Oct 9 '10 at 2:16
    
Excellent link/advice. Followed that, changed to mixed mode. Changed pw for sa, got a 15513 error, but got around this by ticking on 'map to credential' Restarted server - got a bad login via my jar file. Tried creating a new user with un - test, pw - test, still get a bad login error via my JAR. Any other thoughts? –  Simon Oct 9 '10 at 5:31
show 1 more comment

Check that your protocols are enabled in Start\Microsoft SQLServer\Configuration tools\Configuration manager.

On the task bar to the left, select SQL Server Network Configuration, and enable Shared Memory, Named Pipes and TCP/IP.

Select SQL Server Services and restart SQL Server Browser and SQL Server.

See if that helps

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.