Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm not much of a super-user but I've been struggling with this issue for hours and I hope maybe someone here will know how to assist me. I've just installed SQL Server 2008 Developer, I've chosen the stand-alone server on the installation options and ran through the wizard without a problem. I then tried to run the SP2, which I downloaded from here, but I'm failing one test which prevents me from continuing on. The test is:

"Not clustered or the cluster service is up and online".

When I click on the rule for more information it states:

"The machine is clustered, but the cluster is not online or cannot be accessed from one of its nodes...".

I'm not sure how it came to be that the clustering service (whatever this might be) is up or that my machine is clustered because I've installed the stand-alone server.

To verify that I indeed install the stand-alone version, originally, I removed the installation and re-installed it.
Also, it might be relevant to point out that I had at some point in the past SQL Server 2005 trial and SQL Server 2008 Express installed on this machine but they were both uninstalled at the time of this installation.
I need the SP2 installation as I have a DB which I backed up on my 2008 Express but I cannot use it now as the Express was with SP2 (I get a message which says that the DB was created with a newer version).

If there is any additional information which is required please don't hesitate to ask

Update What I ended up doing, as a hack, was to uninstall the developer, reinstall the express and export the db via tasks-export scripts. This included the schema and the data. Then I reinstalled the developer, created my DB, and ran the SQL file.

share|improve this question

3 Answers 3

This mess probably happened because of the previous versions of SQL Server that you had installed. Such Microsoft mastodons normally suffer from an insufficient uninstall process, leaving bits and pieces all over the place. So it is really not advised to install and uninstall them on the same machine. A virtual machine is preferable if you are just trying them out.

First step is to uninstall from the Control Panel all instances of SQL Server, then totally scrub out them out.
See the following articles:

How to uninstall an instance of SQL Server 2005 manually
How to manually uninstall SQL Express if uninstalling from Add/Remove Programs fails

If everything fails, try starting the cluster service, just in order to let the installation complete.

share|improve this answer
    
Hi harrymc, thanks a lot for your comment. I will uninstall my current installation and then go over both instructions to verify no traces are left behind. I do want to point out that I have never installed the cluster version and I don't have any clue on what is the cluster service. How should this service be named? –  Ittai Oct 9 '10 at 14:42
    
It seems to be called "Windows Cluster service" (I don't have any cluster to verify on). –  harrymc Oct 9 '10 at 15:35
    
Harrymc, I've gone through both links and I don't have a "Windows Cluster service" so unfortunately I'm back to square 1. –  Ittai Oct 11 '10 at 8:24
    
I really hate this conclusion of mine: If no other choice, reformat the disk and reinstall Windows and all applications (ouch). These big monsters of Microsoft can really louse-up Windows, so if the idea is only to try them out, then better use a virtual machine. –  harrymc Oct 11 '10 at 9:00
    
Thanks, but I've come up with a patch. I've uninstalled the developer version and reinstalled the express (which has SP2 included) and exported the db manually to an access file. Uninstalled and reinstalled and now I'm going to import the access to the developer. This is not for evaluation but from actual need. –  Ittai Oct 11 '10 at 9:14

One quick fix could be to make sure you don't have another folder of "Microsoft SQL Server" inside Program Files. There should be only one at a time – unless you have set up a clustered environment when you installed SQL server originally.

share|improve this answer

This could happen due to multiple reasons:

  1. Cluster is not up when SQL Setup was started (rerunning the rules won’t help).
  2. If NoLMHash policy is enabled, the Logon account password should be 15 chars.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.