Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Mac Mini with a 40GB system drive and the time has come to move all the user data to an external drive, as I only have 750MB left.

So I plugged in a 1TB firewire drive and used Finder to copy the files across. This failed though as the system drive ran out of space in moments. Upon re-boot the space reappeared so I tried again, this time with rsync. The same problem occurred moments into the copy job.

I have two questions; What is causing the drive to fill (I assume some kind of caching) and how can I avoid it?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

I'm not completely sure why you're running out of space, but if I had to guess, I would think that your swap is expanding while you do the copy job. In order to avoid it, is there any major thing you can temporarily delete, such as a large application?

share|improve this answer
    
Thanks, deleting files got the copy going. –  Keith Bloom Oct 9 '10 at 15:28
add comment

With OS X it is prudent to leave 10% of your drives rated capacity free for swap space. Filling a 40 GB drive to within 750 MB of full is the problem. You will probably either have to free up space on the boot drive to successfully copy user files to another drive or boot the mini in firewire target disk mode and use another system to do the transfer.

share|improve this answer
    
Thanks for the tip and you are spot on. I freed some space it worked. I now have 6GB free and I won't be dropping below that :) –  Keith Bloom Oct 11 '10 at 12:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.