Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new Dell computer running Windows 7 x64 (and no other OS). I live in Mountain Time, as my computer is aware (it says Mountain Time in the Date and Time window, from right-clicking on the taskbar clock and selecting Adjust date/time). However, often, it updates to say a time that's six hours later than it should be. I assume that it's updating to UTC and once Daylight Savings Time is over, it will start updating to seven hours later (assuming that I can't solve it by then and nobody answers this). When I tell it to update the time from the Internet (time.windows.com), it updates to Mountain Time again, though, at some later point, it will again switch to UTC.

Obviously, this behavior is undesirable, as I would like Windows to know what time it really is. Is there any way to fix this?

Update 20 Oct 2010 - I do not believe I have any programs installed that could adjust the clock. I do, however, occasionally boot into Linux Mint Live CD (I've been meaning to install it on my hard drive, but haven't yet), though I doubt this is the problem because the times I've noticed were nowhere near the times that I used the Live CD. After applying the fix below, I haven't really noticed the problem again, though I did manually mess with my clock a bit, which may have masked or shown the symptoms. If I everything is still good in a week, and again once DST is over, I'll answer the question with the fix mentioned below.


I'm trying the solution here, but this isn't easily reproducible (I need to wait for some amount of time, and I'm not sure what that amount is), so I'm posting this question in hopes that somebody can verify if that answer will work or can provide another answer.

share|improve this question
    
Do you have any programs installed that might adjust your clock? –  MBraedley Oct 9 '10 at 20:53
    
@MBraedley I've just answered that in the update; thanks for asking, I should have remembered to check that before posting the question, even though it wasn't the problem. –  Daniel H Oct 21 '10 at 1:06
1  
I have a feeling that Mint was treating the system clock as UTC, updating it accordingly, yet still displaying Mountain Time to you. –  MBraedley Oct 21 '10 at 10:17
    
Using UTC in windows superuser.com/questions/185773/… –  user220467 Apr 28 '13 at 9:10
add comment

1 Answer

up vote 0 down vote accepted

(@MBraedley's feeling above seems correct to me.)

Most (if not all?) Linux systems use UTC by default for system time, and have NTP enabled. If Windows is not using NTP to keep the time updated, then I would expect the time to show incorrectly when booting to Windows after using Linux.

If that is the case, you would have two choices:

  1. Disable UTC in Linux (Set UTC=no in your /etc/default/rcS in a Debian derived system), or
  2. Use UTC in Windows 7 - just found this in another *.stackexchange.com post but already lost the link.

(I think Windows default of using local time as systems time is kind of dumb; personally I like the idea of using UTC as system time much suitable choice.)

I am not familiar with Windows 7 and if it is using NTP by default. Enabling NTP in Windows (if not already enabled) could also be a workable solution?

share|improve this answer
1  
I didn't expect an answer after all this time - thanks. That's probably correct. I'm just surprised that Mint was able to know I was in the Mountain time zone after using NTP to "correct" the computer time (IMHO, live CDs should not modify the host system in ANY WAY without explicit user interaction, for exactly this reason; the main OS(es) can correct for time drift, etc.) –  Daniel H Aug 10 '12 at 16:11
    
I gave you +1 for the good opinion about live CDs should not "correct" the time like this; if the Linux system can find the current time zone automatically as you describe (maybe using IP address to determine the location), then it would be easy step to check if the system time obeys UTC or local time and automatically switch using whatever fits better. Determining that the clock is skewed by 13 minutes 5 seconds 129 milliseconds, and then keeping the hardware clock in that time but adjusting by software would probably be more involved change (and not make much sense)... :-) –  FooF Aug 14 '12 at 3:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.