Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was connected to a linux server over SSH. After performing the following command

cat dmesg.1.gz

the prompt on my SSH session changed from conor@linux:~$ to ␌⎺┼⎺⎼@┌␋┼┤│:·/┌⎺±⎽$

Any text I typed into the terminal was also garbled, even after disconnecting from the SSH session by typing exit, the terminal session which was now with my mac, was still garbled. I resolved the issue by closing the terminal window and opening a new one.

Is there any way to reset the terminal without closing the window and reopening such as a key combination?

share|improve this question

3 Answers 3

up vote 17 down vote accepted

Your terminal has been shifted into “alternate character set” mode. To shift it back out, type

tput rmacs

at your (garbled) shell prompt. Your typing will appear garbled, too, but it will be back to normal after this command finishes.

share|improve this answer
Picked this as the best answer because it explained the reason why it happened in addition to resolving the issue. Mr. Mans answer worked too. – conorgriffin Oct 11 '10 at 17:52
worked on a Linux terminal too :) – logoff Apr 23 at 10:44

I have had this same problem. To fix, click on Shell --> Send Reset. And if that doesn't work. Shell --> Hard Reset. This will reset it without you having to close and reopen the terminal.

share|improve this answer
+1 this is the only solution that worked for me, when something went wrong on the remote side of an ssh connection. – Kelvin Mar 24 '12 at 22:46
⌘R — Send Reset – Will Nov 21 '14 at 17:21

Typing "reset" at the command line (even if you cannot see what you are tying) often helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.