Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have

  • win 7 x64 Home Prem.
  • The HDD is a seagate barracuda, 7200.7 ST3120827AS. 3.5", Serial: 3ms006n6, Firmware: 3.42 (no further updates)
  • NexStar CX External case (drivers installed).

I have three drives:

  • WD320 with OS installed
  • WD750 data storage (internal)
  • seagate 120 (external) - connected via esata board connected to sata on motherboard (MSI p43 neo)

Tried uninstalling HDD in device manager to no effect. Also the internal WD750 is detected as an external drive and win taskbar icon allows for it to be ejected (unlike the seagate).

All drives are configured - Online, Simple, Basic, NTFS, Active, Primary Partition (except c drive).

The seagate was previously used as a primary disk with XP operating system so I deleted the volume and created/reformatted (not quick). HDD is no longer "Active". But did not fix problem.

Background

  • Originally, I installed win 7 with the bios set to IDE and forgot to install the chipset drivers. Then I changed win 7 to install the AHCI drivers, changed the bios to AHCI and rebooted. Win 7 loaded drivers but WD HDD gave problems/crashed. I installed chipset drivers and latest intell storage matrix software thingie (in safe mode). Everything worked fine after that except for the problem of not corrrectly detecting the external drive]

I have noticed that under the driver properties (and similarly in the registry) the two drives are configured differently (e.g. in driver details property capabilities for the WD the value is set to 0000006, CM_DEVCAP_REMOVABLE & EJECTSUPPORTED - whereas the seagate shows 0000080 & CM_DEVCAP_SURPRISEREMOVALOK).

Any easy way to configure things? I tried physically swapping the sata connections on the mainboard without success

So far I have found that a solution to my problem might be to perform some reg changes:

How do I remove the option to eject SATA drives from the Windows 7 tray icon?

share|improve this question

2 Answers 2

It may seem like a stupid question, but do you have the latest manufacturer-specific drivers installed for your eSATA add-in card? I just had essentially the same issue with an external drive (but attached to my motherboard's SATA controller), and it turned out that Microsoft's generic SATA AHCI driver wasn't up to the task: http://superuser.com/questions/197771/windows-7-disk-management-utility-doesnt-show-disk-with-ext3-type-83-partition/197985

share|improve this answer
    
Thanks for the links. Yes, as far as I'm aware - I downloaded and installed the latest nexstar drivers. Also, just installed the latest Intel storage driver 9.6.0.1014 - but did not fix the problem. One thing I haven't tried is to bypass the external case interface board to see if it will detect as external if I plug the drive directly into the mainboard (using the case for power). –  Sam Oct 11 '10 at 10:40
    
By the way, in one of the links Intel seems to state that hot swap is not supported with Esata - I'm not exactly sure what esata is, even though I stated above I was running esata - maybe I'm running just sata? –  Sam Oct 11 '10 at 10:48
1  
Esata is just an extension of sata to the exterior. It will allow hot swap if your controller supports it though. What mobo do you have? –  Canadian Luke Sep 25 '11 at 19:44

This question I asked (and answered) last year might give some insight. It basically comes down to your device, for some reason, registering itself as a Mass Storage device, not a Removable Storage device. There are tools to fix this.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.