Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 2 TB disk in an external SATA dock, formatted with a single ext3 (Linux) partition, which doesn't show up in the Windows 7 Computer Management->Disk Management utility, even as a raw/blank disk. I've verified that there's nothing wrong with the disk by connecting it to my Linux machine and mounting it, and I've verified that the dock is functioning properly by connecting a different FAT32-formatted disk, which mounts flawlessly as expected.

I realize that I can't actually read the ext3 partition without additional software (e.g., Ext3IFS), but why doesn't the disk show up at all? Is there some sort of stupid anti-Linux filter built in? Is there any way to force Windows to recognize the disk, so that I can at the very least use direct block access with it?

Background: I want to clone an identical 2 TB disk onto this one. Due to my hardware layout, it's much easier to have the source disk attached to one machine and the destination disk connected to another, and do the clone over the network (the network is not a bottleneck with switched gigabit ethernet), than it is to hook them both up to one machine.(1) I did this once before when both machines were running Linux, but I've since upgraded the destination machine and decided to switch back to Windows for regular desktop use. I've got Cygwin installed, and have verified that the same basic method (dd + nc) will work, but I can't do anything if Windows doesn't even consider the destination disk to exist.

(1) I only have one eSATA port on each machine. Opening them up just to do this clone is a rather large annoyance. Also, since this is my backup disk, I'd like to eventually automate the cloning from the active disk to another one that I regularly swap with a third disk that I store off-site.

share|improve this question

After further experimentation and head-banging, it turns out that Microsoft's SATA AHCI driver just sucks. After booting to a Linux livecd, I verified that there's nothing wrong with the hardware, and hotplug works exactly as expected in Linux on this machine. Then, just for fun, I decided to see what would happen with the drive plugged in at boot: Windows recognized it as expected. (I didn't try this before because I didn't want to reboot, and other drives worked just fine when hotplugged.)

I then decided to update my BIOS to the latest revision (which I didn't really expect to fix anything, and which didn't, but who knows with Windows) and finally to double-check for updated drivers. I thought I'd downloaded the latest of everything when I built this machine 2 months ago, but it turned out that I needed to install the sounds-like-a-useless-GUI-app "Intel Matrix Storage Manager" which also happens to mention deep in the manual that it includes the Intel SATA AHCI driver. With the non-generic AHCI driver installed, hotplug now works with this drive as well.

Oh, Windows driver bullshit, how I didn't miss you even a little.

share|improve this answer
After further research, it turns out that the Matrix drivers do NOT support the SSD TRIM command (my system disk is an Intel X25M G2 80GB SSD), whereas the generic MS-AHCI drivers do. Luckily, Intel themselves have a newer driver, Rapid Storage Technology, the latest version of which ( does support TRIM, at least according to and . – Greg P. Oct 10 '10 at 21:32
Stupid comment limits. The RST drivers for my Asus P6T-SE, which has the Intel X58 chipset with ICH10R SATA controller are available at… . – Greg P. Oct 10 '10 at 21:33
It's worth mentioning, however, that Intel's drivers (Matrix and RST) properly recognize the internal SATA ports as internal, which means that 'Safely Remove Hardware' is not supported for drives attached to the internal ports. describes some 3rd-party HotSwap! utility that allows for proper cache flushing and dismounting of "internal" drives, but I haven't tried it yet. I haven't been able to find anything like… to properly re-enable it. – Greg P. Oct 10 '10 at 21:38
More fun times: dd under Cygwin doesn't support writing with a block size greater than 512 bytes, which results in a maximum speed of about 5 MB/sec, which is of course completely useless when cloning a 2 TB drive. (I'm going to go ahead and just blame Windows for this.) Luckily it can read with larger block sizes, so I only had to swap the two drives between machines. Still, WTF. Some maybe-useful background:… – Greg P. Oct 10 '10 at 22:19
There's a native dd port. – grawity Dec 12 '11 at 17:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.