Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

when I press the volume buttons on my laptop, usually the system volume is changed.

However, when I do this with VLC it "steals" the presses and adjusts it's own "volume" instead. The system volume is also changed.

I can't find any way to turn this off in VLC. Does anyone know?

Update:
Sorry, some more details I should have included originally:

  • VLC VERSION: 1.1.4 (and a few previous releases, back to about 1.1.0 or so, I think)
  • OS: Win Vista Pro 32
  • HARDWARE: Dell 1720 laptop (the volume buttons are little buttons on the front of the unit, they may work something like "media" keyboard volume buttons)

Update:
The buttons seem to map to Ctrl+Alt+b and Ctrl+Alt+c (according to the shortcut key box in windows shortcut properties) but the VLC advanced preferences hotkeys screen doesn't list these as the keys it uses for volume.

I changed it so there are no volume hotkeys in VLC settings - no luck it still steals the presses and adjusts the volume.

Also, pressing Ctrl+Alt+b or c doesn't change my system volume, so who knows what windows or VLC are doing to recognise those volume buttons.

:(

Update:

This Bug was finally fixed in 1.1.8 - VLC no longer steals volume button presses by default.

share|improve this question
    
What OS/VLC version? On my Win 7 Lenovo laptop I don't see such behaviour - sytem volume is also adjusted when using the volume buttons. Only difference is that volume level is changed by 2 "notches". Without VLC running the volume changes by 1 per button press. But that's adjustable in VLC Tools/Preferences/Audio (with Show Settings->All selected). I suggest you poke around there a bit –  Siim K Oct 13 '10 at 8:09

5 Answers 5

up vote 8 down vote accepted
+50

Known bug : Ticket #3828 (new defect) : QT4 sends processed hotkey events forward, opened 4 months ago :

There is a bug in VLC 1.1.0 QT4 interface that causes processed hotkey events to forwarded. So if volume up key from keyboard is pressed, VLC raises the volume, but it also sends same hotkey event forward and because of this Windows Mixer also raises volume.

Same applies to mute, so both VLC and Windows Mixers are muted. Right way would be that VLC eats all hotkey events it has processed and forwards only those, that it doesn't process.

The only solution is to add your voice to this bug and in the videolan forums, until it's fixed.
Or, as VLC is open source, get the sources and fix the bug, which should be simple enough.

We need more info, such as your operating system and what are the volume keys on your laptop, and what do they generate.

However, you can still try to go into VLC Preferences, Hotkeys section, click on Volume up(down), and try to set or Clear their local and global key definitions. It would be interesting to know what effect this has on the problem.

share|improve this answer
    
OK, I'm an idiot. Turns out it is adjusting the system volume too, so this really is the same issue. The change is very small in system volume so I didn't notice it until I opened up the expanded volume mixer and tried it. Updated question to reflect what's happening. –  MGOwen Oct 15 '10 at 5:16
    
@harrymc I did try that, thinking maybe the volume button was just producing a key combination that happened to be some kind of commonly-accepted standard for volume up. Nope. I changed the hotkeys for volume up and down, but my buttons still affect it. –  MGOwen Oct 15 '10 at 5:18
    
You can test the keys by right-click on any desktop icon, click in "Shortcut key", then press the media key and see if something is displayed. Or if it is intercepted too soon, use randyrants.com/2006/04/sharpkeys_21.html –  harrymc Oct 15 '10 at 7:34
    
Thanks, I tried the shortcut thing and it worked, but VLC and windows ignore it anyway, see updated answer above. I'll try the sharpkeys thing. It's a Dell Inspiron 1720, but I believe the hardware difference between those two 1720's is zero. –  MGOwen Oct 20 '10 at 0:32

Someone made a patch at http://forum.videolan.org/viewtopic.php?f=14&t=79258&start=20 - the patched DLL for 1.1.4 works great on my Win7 box.

share|improve this answer

The extended "application keys" are not meant to be global "hotkeys" like Win+L etc. The focused window receives the keypress first and has a chance to process it, just like other normal keys. This is by design.

You can work around this issue by switching the keyboard focus away from VLC. Using the mouse, you can click another window or desktop / taskbar. Using the keyboard, you can either Alt+Tab, or if VLC is the only window, Win+B to focus the "system tray".

share|improve this answer
    
I understand how focus works, VLC is now capturing the event instead of passing it on like other apps do and like previous versions (pre 1.01, I think?) of VLC did. It's obviously not desireable behaviour, and shouldn't be the default. Still, that's another issue; I just want to know how to fix it, and since VLC has a million settings to tweak, you'd think there'd be at least one or two ways to fix it properly. –  MGOwen Oct 14 '10 at 0:23
    
@MGOwen: I apologize for spelling out the obvious :) I agree that processing the multimedia keys by an app should probably be optional, and doesn't seem to be in VLC. –  Hugh Allen Oct 14 '10 at 0:45
    
Thanks @Hugh, and I do appreciate your time, thank you. –  MGOwen Oct 20 '10 at 0:13

Update to VLC 1.1.7.
Open Preferences and under "Show Settings" select "All."
Navigate to Interface > Main interfaces > Qt
Check the box that says: "Ignore keyboard volume buttons."
Click the "Save" button.

(Complain to the devs that this is not the default.)

share|improve this answer
    
Works beautifully. Glad they added this option. Thanks @ave. –  Travis Feb 20 '11 at 19:14

I had this problem with the mute. Solution was to go into the VLC hotkeys settings and map the mute button as the mute hotkey - VLC then stopped processing the mute key (but registers that a key was pressed, it flashes the current VLC volume on screen).

Setting volume up/down hotkeys to the media keys as globals results in VLC always taking the volume up/down keys - but not changing your system volume, whether VLC has focus or not. If I clear the global setting, system volume is changed when VLC doesn't have focus, if it has focus then it changes volume.

It is buggy, but that seems the best solution and how I'm handling it.

(VLC 1.1.5, Dell D830 laptop)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.