Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Whenever I format my computer, I usually just copy/paste all the .ttf and .fon files into the Fonts system folder.

I can't be sure 100%, but I think that after I did that, Firefox stopped displaying some website's fonts correctly, and I mean the usual default ones, like Arial, Helvetica, etc.

I don't have this problem in any other program, other than Firefox.

Here is a screenshot of what Digg looks on my laptop right now:

enter image description here

It looks weird, the font is messed up somehow.

How do I fix it? I'm on Windows 7, Firefox 3.6.10.

share|improve this question
    
Tools > Options > Content > Fonts & Colors - What is selected? – random Oct 11 '10 at 13:16
up vote 5 down vote accepted

This specific problem is due to installing a version of the Helvetica font (very commonly used on the web) that either Windows or Firefox can't display. To confirm, all you have to do is paste the following text in your Firefox address bar and hit enter:

data:text/html,
Helvetica
   <font face="Helvetica" size="25">abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ</font>

Helvetica Neue
  <font face="Helvetica Neue" size="25">abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ</font>

If it displays as weird symbols, then you can be sure that's your problem.

To fix it, all you have to do is go to %WINDIR%\Fonts and delete all the fonts named Helvetica.

If for some reason, Windows doesn't allow you to, you have to go to the registry, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts and then delete all the entries that have Helvetica on their name.

If you are using Windows 7 64-bit, you also have to delete the Helvetica entries from the following registry key.

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Fonts

After this, you only need to reboot your computer and the fonts will be displayed correctly again. At least that fixed it for me.

share|improve this answer
    
Great answer, this fixed it for me too. Does Windows have any Helvetica font by default? – Virtlink Sep 6 '13 at 13:21

I was just struggling with the same problem (albeit with Google Chrome) and stumbled upon this topic. Because I'm using a PC at work, I don't have the privileges to make registry edits. I found another workaround however, which probably only works on Chrome, but at least it fixed the problem for me. So although it's not about Firefox, I still want to share it, in case somebody else ends up in this topic as well.

  1. Open Google Chrome
  2. Open a new tab and enter the following in the address bar:

chrome://flags/#disable-direct-write

  1. Click "enable" to enable this switch, disabling the use of Microsoft DirectWrite by Google Chrome.
  2. Close and re-open Chrome.

Source & credits: https://youtu.be/cHHBnHRcOjQ

share|improve this answer

Go to your firefox preferences, under the "Content" tab there should be a "Default Font" combobox. Try switching the setting to one of the usual Microsoft fonts. If not, it is possible that you simply don't have the Microsoft fonts installed. Apparently, you can get some of the core fonts here: http://web.nickshanks.com/fonts/microsoft-core-web-fonts

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .