Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my MacBook (13 inch aluminum late 2008) the backtick key (`) does not work by itself. In order to insert a backtick, I have to press Option + `.

The tilde (~) works fine.

I'm using the default US keyboard layout. Any ideas why this is happening and how to fix it?

share|improve this question
    
Check your language settings. While the keyboard may be correct, your regional settings may be the problem. –  user3463 Oct 10 '10 at 18:34
    
I checked them and they all seem correct. But the problem persists. –  Wuffers Oct 10 '10 at 18:36
    
What Mac OS X version are you using? Did you upgrade or reinstall you system? –  Daniel Beck Oct 10 '10 at 22:12
    
I did do a clean reinstall a while ago because I messed up my system (Installed GRUB on it, human error). And I am running 10.6.4. –  Wuffers Oct 10 '10 at 22:39

1 Answer 1

up vote 1 down vote accepted

Go to System Preferences > Language & Text > Input Sources. There, check Show Input menu in menu bar, and make sure the first item in the list - Keyboard & Character Viewer is also checked.

Now you can open the Keyboard Viewer from the new icon in the menu bar. Green keys are "dead keys" (i.e. they modify the next character you input, like ´ + e = é). Press shift and/or alt to view the characters you enter while pressing those modifier keys.

I assume that the ` key is -- without modifiers -- displayed in green. If not, try changing your layout temporarily, maybe it will snap back.

Otherwise, check a few other applicable Input Sources in the same system preferences pane (British, US, US Extended and US International PC all match your printed keyboard layout except #/£) and switch between them in the list for the new menu bar item. The Keyboard Viewer will update immediately, so you can look for a layout you like, in terms of dead keys and even characters you type while pressing alt (those not printed on the keyboard).

(I have an international english keyboard, so I don't have first-hand experience with your layout)

share|improve this answer
    
Thanks, but when I have the keyboard viewer active, the backtic key isn't green. None of them are. –  Wuffers Oct 10 '10 at 22:47
    
Just after posting that, I changed to a US International layout, with backtic as a 'dead key' It seems to be working now. Even though I have to press space to terminate it. Thanks! –  Wuffers Oct 10 '10 at 22:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.