Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was having issues with my older Linksys wireless router and decided to upgrade to a Linksys E3000. However, after upgrading, I still have the same issues.

What happens is that I will be connected on my laptop (via wireless) and suddenly my connection will be dropped. Nothing I do seems to allow me to connect. My wife's laptop does the same thing. Wired connections have no issue, and if I give the laptops static IPs I have no issue.

I looked at the log in the web interface and get the following lines repeated when I try to connect:

Sun, 10 Oct 2010 16:18:08 received DISCOVER from 00:21:00:3B:D7:70
Sun, 10 Oct 2010 16:18:09 sending OFFER to 255.255.255.255 with 192.168.1.136

It looks like the router is trying to offer my laptop an IP, but the laptop does not take it. I verified that this is the MAC address of my laptop. I also do not understand why the IP that it is trying to assign is so high. My IP range is from 192.168.1.100 - 150 and I only have a a few devices connected.

I ran a capture using wireshark, but I don't really know what to look for.

share|improve this question
add comment

1 Answer

We always use static IPs at home for the wireless. Consumer grade WAPs (and some business-class ones) just have really crappy DHCP. For whatever reason (I hate to say 'it should be easy!', but it really seems like it should). Whenever we get a new router, we figure we'll try its DHCP, and eventually we go back to static because it's just not worth the aggrivation.

At work, if there are too many devices out there to bother with static, the solution when it starts getting flaky is to just power cycle the WAP, and things connect ok for a few more days or weeks (or just buy a sturdier router). Part of me thinks they do it intentionally to upsell.

Since the number of IPs at home is typically less than 10, static IPs are just the path of least resistance in this case.

share|improve this answer
    
I have seen this before with other Linksys routers. Rebooting the router does the trick for my clients (22 users working fI have seen this before with other Linksys routers. Rebooting the router does the trick for my clients (22 users working from home). –  steve.lippert Oct 11 '10 at 3:23
    
This is my first issue with any Linksys wireless router. And the old router worked fine until we moved. I thought it was interference at first because there is much more wireless activity where we moved to (devices in other houses and near by businesses). But the DHCP logs make me think that's not the issue. Static IPs is not a huge deal until somebody comes over and wants to use the wireless. Linux makes it easy to setup different IP settings for different wireless connections, Windows does not. –  JamesArmes Oct 11 '10 at 13:02
    
Our DHCP seems to work find for the random friend connecting occasionally. It's reliable day-to-day use that never seems to pan out for me. –  Kara Marfia Oct 12 '10 at 22:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.