Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I need to temporarily disable 302 redirects in Firefox. How can I do this? I tried going to tools > options > advanced > general > check warn me when sites try to redirect or reload the page, but that didn't work, 302 redirects are still followed. Is there anywhere in about:config that I can disable 302 redirects?

share|improve this question
May be this will help you out. Link –  0MV1 May 26 at 14:20

2 Answers 2

call about:config and set network.http.redirection-limit to 0. But you won't be able to access the moved page.

share|improve this answer
As I don't have Firefox installed right now, and for others benefit - What does changing this setting as advised do? Would hope that the user would get some warning (rather than a blank page) and / or a offer to load the next redirect. –  user66001 Jan 19 '13 at 21:21
@user66001 This setting is absolutely useless for end user. It is a limit of redirects before Firefox decides that it got into a redirect loop and stops following redirects. If you set it to 0 you'll get "Firefox decided that it got a redirect which will not end" error message immediately. –  hijarian Jun 30 at 17:43
To anyone reading this answer: strictly speaking, this is the solution as OP asked: 302 redirects will stop being followed. But if you actually want manual redirection, then it's not the solution you want. –  hijarian Jun 30 at 17:44

Not specific to Firefox, but you could use the Fiddler debugging proxy, and set a breakpoint on the response. Or use a script like (I guess):

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.